Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40342 - [bind] named crashes when "type forward" used for a zone.

Attached to Project: Community Packages
Opened by AMM (amish) - Tuesday, 13 May 2014, 04:22 GMT
Last edited by Sébastien Luttringer (seblu) - Thursday, 15 May 2014, 22:29 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Sébastien Luttringer (seblu)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I have this line in named.conf

zone "multi.uribl.com" {
type forward;
};

I use OpenDNS forwarders in main options but I wanted "exception" for "multi.uribl.com".

So I had added above 3 lines.

This worked perfect in 9.9.5.W1-2 but after updating to 9.10.0.P1-1 named started crashing immediately on start.

Removing/commenting lines resolves issue but "exception" is lost.


Additional info:
* package version(s)
named-9.10.0.P1-1

* config and/or log files etc.

Backtrace log is attached.


Steps to reproduce:
Add these lines in named.conf and restart named

options {
...
...
forward first;
forwarders { 208.67.222.222 ; 208.67.220.220 ; }; //OpenDNS
}

zone "multi.uribl.com" {
type forward;
};
This task depends upon

Closed by  Sébastien Luttringer (seblu)
Thursday, 15 May 2014, 22:29 GMT
Reason for closing:  Deferred
Additional comments about closing:  Workaround is provided. Will be fixed in next upstream release.
Comment by AMM (amish) - Tuesday, 13 May 2014, 04:40 GMT
This bug/crash can be fixed by specifying empty forwarders like this:

zone "multi.uribl.com" {
type forward;
forwarders { };
};

But named should not have crashed even if forwarders line is missing.

However there is another similar looking crash that soon follows which is reported at bug#40304

Downgraded back to 9.9.5.W1-2
Comment by Mukund Sivaraman (muks) - Tuesday, 13 May 2014, 06:37 GMT
Hi AMM

Thank you for the recipe to reproduce this issue. A fix for the problem is in review upstream. The upstream ticket number is ISC-Bugs #35979.
Comment by AMM (amish) - Tuesday, 13 May 2014, 07:08 GMT
How to see upstream ticket OR fix? Searched a lot but could not find exact link.
Comment by Mukund Sivaraman (muks) - Tuesday, 13 May 2014, 08:33 GMT
The upstream BIND issue tracker is a closed one. The upstream ticket number is given for reference, so that if you or anyone else contacts the BIND developers about this issue, you can point to this ticket number.

As a workaround, try this:

zone "multi.uribl.com" {
type forward;
forwarders {};
};

If you mail <bind9-bugs@isc.org> reporting this problem, you'll get email to keep track of this bug, and we'll send you a patch to try.
Comment by AMM (amish) - Tuesday, 13 May 2014, 08:41 GMT
Oh ok. Thanks for clarification. And I found it funny that you gave my own workaround back to me! :D

Anyway, I suppose this bug can be closed.
Comment by Mukund Sivaraman (muks) - Tuesday, 13 May 2014, 08:52 GMT
Haha.. sorry I didn't realize you posted the same above. :)

The crash has been fixed and the fix will be in a release soon (after it's been reviewed, merged, etc.). If you want the patch before that, please mail us. Thank you again for getting back to us with information necessary for debugging this issue.
Comment by AMM (amish) - Tuesday, 13 May 2014, 08:58 GMT
Since workaround works I think currently I dont need patch. Already spent lot of time on this. Will wait for next release.

Thanks for quick patch and reply.

Loading...