Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40338 - [mumble] build fails

Attached to Project: Community Packages
Opened by Joel Teichroeb (klusark) - Monday, 12 May 2014, 23:03 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Thursday, 15 May 2014, 02:15 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

g++ -c -include release/mumble -pipe -Wfatal-errors -fvisibility=hidden -Wshadow -Woverloaded-virtual -Wold-style-cast -Wconversion -Wsign-compare -Wall -Wextra -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -Wall -W -D_REENTRANT -DPLUGIN_PATH=/usr/lib/mumble -DRESTRICT=__restrict__ -D_FORTIFY_SOURCE=2 -DMUMBLE_VERSION_STRING=1.2.5 -DMUMBLE_VERSION=1.2.5 -DMUMBLE -DNO_CRASH_REPORT -DUSE_OPUS -DUSE_ALSA -DUSE_OSS -DUSE_PULSEAUDIO -DUSE_BONJOUR -DUSE_DBUS -DNO_UPDATE_CHECK -D_REENTRANT -DQT_NO_DEBUG -DQT_SVG_LIB -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4/QtSvg -I/usr/include/qt4 -I/usr/include/qt4/QtDBus -I../../src -I. -I../bonjour -I../../celt-0.7.0-src/libcelt -I/usr/lib/oss/include -Irelease -I/usr/include/opus -I/usr/include/alsa -I/usr/include/avahi-compat-libdns_sd -I. -o release/PulseAudio.o PulseAudio.cpp
OSS.cpp: In member function 'virtual void OSSInput::run()':
OSS.cpp:261:1: error: jump to label 'out' [-fpermissive]
out:
^
compilation terminated due to -Wfatal-errors.
Makefile.Release:2567: recipe for target 'release/OSS.o' failed
make[2]: *** [release/OSS.o] Error 1
make[2]: *** Waiting for unfinished jobs....

...snip lots more lines

Steps to reproduce:
sudo extra-x86_64-build
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Thursday, 15 May 2014, 02:15 GMT
Reason for closing:  Fixed

Loading...