Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40331 - [firefox] segfaults on some websites

Attached to Project: Arch Linux
Opened by patrick (potomac) - Monday, 12 May 2014, 22:37 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 14 May 2014, 18:54 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Ionut Biru (wonder)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 10
Private No

Details

Description: after upgrading to firefox 29.0.1 a crash will occur ( segfault ) if I go on these websites :

1) https://robertsspaceindustries.com/

segfault with this error message in the console :

No permission to use the keyboard API for https://robertsspaceindustries.com

2) http://thp.io/2014/petals/play/

segfault with no error message in the console

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:

- install firefox 29.0.1
- go to https://robertsspaceindustries.com/ --> a segfault will occur
- go to http://thp.io/2014/petals/play/ --> a segfault will occur

according to this thread the bug doesn't occur with firefox 29.0 :

https://bbs.archlinux.org/viewtopic.php?pid=1414881
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 14 May 2014, 18:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  firefox 29.0.1-2
Comment by Philipp Wolfer (phw) - Tuesday, 13 May 2014, 06:35 GMT
I just tested this on my system with the websites posted above:

* Current firefox-29.0.1-1 package -> segfaults
* Downgraded to Firefox 29.0 -> no segfault
* Official Firefox 29.0.1 binaries -> no segfault

I don't get any relevant output that gives me more information on the cause of the crash.
Comment by farid (osc) - Tuesday, 13 May 2014, 14:22 GMT
i also confirm this.

hope this helps:

#0 0x0000000000000000 in ?? ()
#1 0x00007ffff4d63cb3 in ?? () from /usr/lib/firefox/libxul.so
#2 0x00007ffff4d50e8c in ?? () from /usr/lib/firefox/libxul.so
#3 0x00007ffff4d539f7 in ?? () from /usr/lib/firefox/libxul.so
#4 0x00007ffff4d6338e in ?? () from /usr/lib/firefox/libxul.so
#5 0x00007ffff469ced5 in ?? () from /usr/lib/firefox/libxul.so
#6 0x00007ffff43687fc in ?? () from /usr/lib/firefox/libxul.so
#7 0x00007ffff4364ad7 in ?? () from /usr/lib/firefox/libxul.so
#8 0x00007ffff54cd320 in ?? () from /usr/lib/firefox/libxul.so
#9 0x00007ffff54c0b3f in ?? () from /usr/lib/firefox/libxul.so
#10 0x00007ffff54c041b in ?? () from /usr/lib/firefox/libxul.so
#11 0x00007ffff54bffe1 in ?? () from /usr/lib/firefox/libxul.so
#12 0x00007ffff552cb33 in ?? () from /usr/lib/firefox/libxul.so
#13 0x00007ffff552c0f6 in ?? () from /usr/lib/firefox/libxul.so
#14 0x00007ffff54c6dc3 in ?? () from /usr/lib/firefox/libxul.so
#15 0x00007ffff54c041b in ?? () from /usr/lib/firefox/libxul.so
#16 0x00007ffff54bfc69 in ?? () from /usr/lib/firefox/libxul.so
#17 0x00007ffff5436218 in ?? () from /usr/lib/firefox/libxul.so
#18 0x00007ffff5169a2c in ?? () from /usr/lib/firefox/libxul.so
#19 0x00007ffff515e8d9 in ?? () from /usr/lib/firefox/libxul.so
#20 0x00007ffff5752540 in ?? () from /usr/lib/firefox/libxul.so
#21 0x00007ffff5752201 in ?? () from /usr/lib/firefox/libxul.so
#22 0x00007ffff46700f8 in ?? () from /usr/lib/firefox/libxul.so
---Type <return> to continue, or q <return> to quit---
#23 0x00007ffff467208a in ?? () from /usr/lib/firefox/libxul.so
#24 0x00007ffff55da7aa in ?? () from /usr/lib/firefox/libxul.so
#25 0x00007ffff55da3ff in ?? () from /usr/lib/firefox/libxul.so
#26 0x00007ffff55f42fa in ?? () from /usr/lib/firefox/libxul.so
#27 0x00007ffff50596df in ?? () from /usr/lib/firefox/libxul.so
#28 0x00007ffff5059324 in ?? () from /usr/lib/firefox/libxul.so
#29 0x00007ffff5039f1c in ?? () from /usr/lib/firefox/libxul.so
#30 0x00007ffff50419a7 in ?? () from /usr/lib/firefox/libxul.so
#31 0x00007ffff5019cfc in ?? () from /usr/lib/firefox/libxul.so
#32 0x00007ffff507473b in ?? () from /usr/lib/firefox/libxul.so
#33 0x00007ffff5679f63 in ?? () from /usr/lib/firefox/libxul.so
#34 0x00007ffff56db87a in ?? () from /usr/lib/firefox/libxul.so
#35 0x00007ffff57e492e in ?? () from /usr/lib/firefox/libxul.so
#36 0x00007ffff57df1e8 in ?? () from /usr/lib/firefox/libxul.so
#37 0x00007ffff57dd80b in ?? () from /usr/lib/firefox/libxul.so
#38 0x00007ffff57dd64f in XRE_main () from /usr/lib/firefox/libxul.so
#39 0x000000000040f394 in _start ()
Comment by Felix Yan (felixonmars) - Wednesday, 14 May 2014, 08:03 GMT
I just tried to build firefox with clang, and it doesn't have these crashes anymore. Looks like yet another gcc 4.9 problem.
Comment by Felix Yan (felixonmars) - Wednesday, 14 May 2014, 18:20 GMT
29.0.1-2 (built with clang) has been pushed to [extra], please test with it, thanks.
Comment by Evangelos Foutras (foutrelis) - Wednesday, 14 May 2014, 18:53 GMT
Works for me; thanks for handling the rebuilds.

Loading...