Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40310 - [wine] compiling with gcc 4.9.0 breaks wine packages

Attached to Project: Community Packages
Opened by Scarlett Black (SierraWhite) - Sunday, 11 May 2014, 17:40 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Tuesday, 20 May 2014, 01:21 GMT
Task Type Bug Report
Category Packages: Multilib
Status Closed
Assigned To Florian Pritz (bluewind)
Sven-Hendrik Haase (Svenstaro)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:

Wine packages compiled with gcc 4.9.0 appear to be broken, causing mono and gecko installations to fail repeatedly. MSI installer applications refuse to run.

Additional info:

see bug report: http://bugs.winehq.org/show_bug.cgi?id=36453

I've managed to reproduce this issue on wine 1.7.18 and 1.6.2 from the AUR. A user also reported strange (possibly related) behavior at: https://bugs.archlinux.org/task/35313

Attempting to install all versions of .NET result in similar output:

Executing w_do_call dotnet20
Executing load_dotnet20
Executing w_do_call remove_mono
Executing load_remove_mono
------------------------------------------------------
Mono does not appear to be installed.
------------------------------------------------------
Executing w_do_call fontfix
Executing load_fontfix
Setting Windows version to win2k
Executing winetricks_early_wine regedit C:\windows\Temp\_dotnet20\set-winver.reg
Current wine does not have wine  bug 30845 , so not applying workaround
Executing wine dotnetfx.exe
fixme:advapi:DecryptFileA ("C:\\users\\XXXXXX\\Temp\\IXP000.TMP\\", 00000000): stub
ntlm_auth: /usr/lib/libiniparser.so: no version information available (required by ntlm_auth)
fixme:advapi:LsaOpenPolicy ((null),0x33f2d8,0x00000001,0x33f2c4) stub
fixme:advapi:LsaClose (0xcafe) stub
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
------------------------------------------------------
Note: command 'wine dotnetfx.exe' returned status 84. Aborting.

Steps to reproduce:

1. Compile wine versions with gcc 4.9.0
2. Attempt to run any msi based installer (dotnetfx, vcrun, etc).
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Tuesday, 20 May 2014, 01:21 GMT
Reason for closing:  Fixed
Comment by Doug Newgard (Scimmia) - Sunday, 11 May 2014, 19:47 GMT
What gcc package? Specific versions, please.
Comment by Scarlett Black (SierraWhite) - Sunday, 11 May 2014, 20:27 GMT
Oops, sorry about that. This package: https://www.archlinux.org/packages/multilib/x86_64/gcc-multilib/

Specific version:

------------------------------------------------------
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-unknown-linux-gnu/4.9.0/lto-wrapper
Target: x86_64-unknown-linux-gnu
Configured with: /build/gcc-multilib/src/gcc-4.9-20140507/configure --prefix=/usr --libdir=/usr/lib --libexecdir=/usr/lib --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=https://bugs.archlinux.org/ --enable-languages=c,c++,ada,fortran,go,lto,objc,obj-c++ --enable-shared --enable-threads=posix --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-clocale=gnu --disable-libstdcxx-pch --disable-libssp --enable-gnu-unique-object --enable-linker-build-id --enable-cloog-backend=isl --disable-cloog-version-check --enable-lto --enable-plugin --enable-install-libiberty --with-linker-hash-style=gnu --enable-multilib --disable-werror --enable-checking=release
Thread model: posix
gcc version 4.9.0 20140507 (prerelease) (GCC)
-----------------------------------------------------
Comment by Doug Newgard (Scimmia) - Sunday, 11 May 2014, 20:39 GMT
Alright, that is 4.9.0-2, so it wasn't fixed by those updates.
Comment by Sven-Hendrik Haase (Svenstaro) - Monday, 12 May 2014, 01:24 GMT
Well, there isn't really anything we can do here. We can't roll gcc back, we can't compile with clang and we can't really fix the root cause. Gotta wait for wine devs to do it.
Comment by Felix Yan (felixonmars) - Thursday, 15 May 2014, 02:29 GMT
Upstream bug report: https://bugs.winehq.org/show_bug.cgi?id=36139

A quick look suggests compiling with "-O0" would make the problem go away, but I'm not sure if it's good for us to do it...
Comment by Sven-Hendrik Haase (Svenstaro) - Monday, 19 May 2014, 02:55 GMT
I applied the patch from the bug report. Please test rel -2.
Comment by Adam Hirst (aphirst) - Monday, 19 May 2014, 13:50 GMT
Still fails for me on the test case that I've been trying, i.e. installing the Visual C++ 2010 runtime using winetricks. Attached is the output on installation failure (using wine 1.7.19-2 on a clean wineprefix), and I can provide more info if needed. I'll also put this same info up on the winehq bug tracker.
Comment by Adam Hirst (aphirst) - Monday, 19 May 2014, 16:18 GMT
After installing lib32-libxslt (which pulls lib32-libxml2 as another dependency, seemingly the relevant one for this case), package releases -2 (and -3) seem to now work just fine. So, my bad, this appears to be fixed now.

Loading...