Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40262 - [kdebase-workspace] systemsettings locale doesn't have country list

Attached to Project: Arch Linux
Opened by zless (roentgen) - Wednesday, 07 May 2014, 20:00 GMT
Last edited by Andrea Scarpino (BaSh) - Thursday, 08 May 2014, 08:59 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

As shown in the screenshot at http://i.imgur.com/JqxEATQ.png the Locale module of the KDE system settings is missing the list of countries.

As a consequence the number formats and other localization features don't work as desired in programs that use them (e.g KMyMoney).

Additional info:
kdebase-workspace 4.11.9-2
[testing] enabled

I've also tested with another freshly created user and it behaves the same.

It worked fine at some point but I can't tell which is the version that broke it.

I didn't yet report this at bugs.kde.org as I'm waiting to see what the Arch devs say about it.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Thursday, 08 May 2014, 08:59 GMT
Reason for closing:  Not a bug
Comment by Andrea Scarpino (BaSh) - Wednesday, 07 May 2014, 22:19 GMT
I guess you are using NoExtract in pacman.conf or you did run localepurge. If so, please be sure /usr/share/locale/all_language exists. Also, please take a look to http://blog.andreascarpino.it/localepurge-the-arch-way/
Comment by zless (roentgen) - Thursday, 08 May 2014, 06:11 GMT
The localepurge hint is spot on.
Thanks and sorry for the noise.

Loading...