Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40260 - [sshfs] makes applications/desktop lag/freeze ?

Attached to Project: Community Packages
Opened by Gu1 (Gu1) - Wednesday, 07 May 2014, 17:50 GMT
Last edited by Antonio Rojas (arojas) - Wednesday, 21 June 2017, 18:55 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
I usually use sshfs to mount remote folders.
Recently, my whole desktop started freezing when I launched or closed some applications (vlc, gedit, evince, eog).
The freezes only last for about 20 seconds and then it stops freezing.

I did not find the cause, until my last reboot.. I thought the freezing stopped, but when I mounted an sshfs folder, it started again. When I unmounted it, it stopped.

The freezing does not seem to occur when I launch the applications from the menu (e.g without a file as argument); but then when I try to open a file, it freeze. For some applications (evince..) it freezes when I close the application, even if I did not open a file.

I tried to find the cause behind this by attaching GDB on a freezed applications, without much success..


Additional info:
sshfs 2.5-1
cinnamon 2.2.5


Steps to reproduce:
mount a remote folder with sshfs somewhere in my ~
launch a graphical application (vlc, evince, gedit, eog...)
This task depends upon

Closed by  Antonio Rojas (arojas)
Wednesday, 21 June 2017, 18:55 GMT
Reason for closing:  Upstream
Additional comments about closing:  Report upstream if still valid
Comment by Marco Santos (numian) - Monday, 14 July 2014, 15:50 GMT
I had the same problem.

After messing around with strace I've discovered that the origin of (my) lag was the recently used file list.

I've hammered the file recently-used.xbel as described here: http://forums.linuxmint.com/viewtopic.php?f=110&t=93354

rm -f $HOME/.local/share/recently-used.xbel
mkdir $HOME/.local/share/recently-used.xbel


There's no lag anymore.
Comment by Gu1 (Gu1) - Monday, 14 July 2014, 17:08 GMT
Thanks, this seem to do the trick.
Still, I'd like to understand where this bug comes from in the first place... It was working fine a few months ago

Loading...