Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40256 - [gcc] broken ffmpeg because of gcc 4.9

Attached to Project: Arch Linux
Opened by ux (ubitux) - Wednesday, 07 May 2014, 07:51 GMT
Last edited by Allan McRae (Allan) - Friday, 09 May 2014, 01:22 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

GCC 4.9 has a serious regression that affects at least FFmpeg. FFmpeg was recently rebuild with 4.9, so it's now broken. The issue is fixed in GCC upstream, see http://gcc.gnu.org/bugzilla/show_bug.cgi?id=60902#c34

The bug affects the golomb code, and it's known to break at least the flac decoding (so this affects every players and apps depending on the decoder). It may affect several other codecs.

The GCC bug fix should be backported and FFmpeg rebuild.
This task depends upon

Closed by  Allan McRae (Allan)
Friday, 09 May 2014, 01:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  gcc-4.9.0-2
Comment by Mihail Ivanov (x0r) - Wednesday, 07 May 2014, 09:57 GMT Comment by ux (ubitux) - Wednesday, 07 May 2014, 10:15 GMT
"could not find decoder for x264" is likely not the VLC error message, because it makes no sense. If it's unable to find a decoder, it's probably unrelated to this bug.
Comment by Bartłomiej Piotrowski (Barthalion) - Thursday, 08 May 2014, 14:45 GMT
I've rebuilt FFMpeg and MariaDB locally with the new gcc from [testing] and everything seems to work fine now.

Loading...