Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40253 - [ati-dri] Significant performance regression in Mesa 10.1.2-1

Attached to Project: Arch Linux
Opened by Andrew D. (andrewd18) - Tuesday, 06 May 2014, 23:54 GMT
Last edited by Laurent Carlier (lordheavy) - Wednesday, 07 May 2014, 06:47 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

After upgrading to Mesa 10.1.2-1 from Mesa 10.1.1-2, users reported significant performance regressions. See: https://bbs.archlinux.org/viewtopic.php?id=181171 I was also able to recreate this using my ATI HD6850 and Europa Universalis 4, Unigine Valley benchmark, and other OpenGL applications. So far this seems to be limited to ATI cards.

Downgrading to 10.1.1-2 resolved the issue.


Steps to reproduce:
* Use an ATI video card
* Use Radeon open-source graphics
* Upgrade to Mesa 10.1.2-1
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Wednesday, 07 May 2014, 06:47 GMT
Reason for closing:  Upstream
Comment by Bret Towe (magnade) - Wednesday, 07 May 2014, 03:14 GMT
replacing libstdc++.so.6 with the arch 32bit copy in Steam/ubuntu12_32/steam-runtime/i386/lib
also fixes the problem
as it looks like a glibc version mismatch
Comment by Jan de Groot (JGC) - Wednesday, 07 May 2014, 05:50 GMT
This is a bug in the steam package. It shouldn't supply its own libstdc++. This is what happens when linking gcc 4.9 compiled c++ libraries with older libstdc++ libraries.
Comment by Laurent Carlier (lordheavy) - Wednesday, 07 May 2014, 06:47 GMT
@magnade

This is not our bug. You must remove libstdc++.so.6 from steam runtime, replacing it is useless.

Loading...