FS#40249 - [vlc] x264 doesn't work with the newest ffmpeg

Attached to Project: Arch Linux
Opened by Mihail Ivanov (x0r) - Tuesday, 06 May 2014, 20:34 GMT
Last edited by Giovanni Scafora (giovanni) - Sunday, 19 April 2015, 13:30 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I've tried upgrading my ffmpeg lib today, then VLC gave me an error "could not find decoder for x264"
Downgrading ffmpeg fixed the issue.

Additional info:
VLC 2.1.4
new version ffmpeg (1:2.2.2-1)
old version ffmpeg 1:2.2.1-1)

Steps to reproduce:
Install VLC, upgrade/install the newest version of ffmpeg, try playing a x264 encoded video - you get "no decoder" error.
This task depends upon

Closed by  Giovanni Scafora (giovanni)
Sunday, 19 April 2015, 13:30 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Wednesday, 07 May 2014, 16:25 GMT
x0r, does it work now that ffmpeg has been rebuilt with gcc 4.8?
Comment by Mihail Ivanov (x0r) - Wednesday, 07 May 2014, 23:09 GMT
nope, same error:
No suitable decoder module:
VLC does not support the audio or video format "h264". Unfortunately there is no way for you to fix this.
Comment by ux (ubitux) - Friday, 09 May 2014, 07:27 GMT
This works for me:

> ffmpeg -v error -f lavfi -i testsrc -t 5 -y /tmp/out.mp4
> ffprobe -v error -of flat -show_entries stream=codec_name /tmp/out.mp4
> vlc /tmp/out.mp4

If it does for you, please share your broken sample.
Comment by Mihail Ivanov (x0r) - Sunday, 11 May 2014, 22:37 GMT
Do you do the vlc gen cache? Somehow I got so many problems when doing this earlier so nowadays I am afraid to :)
Comment by Michael Murphy (mmstick) - Tuesday, 27 May 2014, 17:26 GMT
I don't have any problems decoding H.264 videos here.
Comment by mattia (nTia89) - Monday, 17 November 2014, 17:48 GMT
an easy and reliable way to get an example file?