Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40227 - [gptfdisk] 0.8.10 has superfluous dependency on icu

Attached to Project: Arch Linux
Opened by Garry Roseman (sitquietly) - Monday, 05 May 2014, 17:58 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 07 May 2014, 08:45 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: gptfdisk declares that it depends on icu but
according to the current README from upstream it does not:
=====================================
In addition, note these requirements:

* The ICU library (http://site.icu-project.org), which provides support for
Unicode partition names, is optional on all platforms except Windows, on
which it's not supported. Using this library was required to get proper
UTF-16 partition name support in GPT fdisk versions prior to 0.8.9, but
as of that version it should not longer be required. Nonetheless, you can
use it if you're having problems with the new UTF-16 support. This
library is normally installed in Linux and OS X, but you may need to
install the development headers (libicu-dev or something similar in
Linux; or the libicu36-dev Fink package in OS X). To compile with ICU
support, you must modify the Makefile: Look for commented-out lines that
refer to USE_UTF16, -licuuc, -licudata, or -licucore. Uncomment them and
comment out the equivalents that lack these lines.
====================================

I suggest removing icu from the depends array.


Steps to reproduce:
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 07 May 2014, 08:45 GMT
Reason for closing:  Not a bug
Additional comments about closing:  gptfdisk doesn't currently depend on icu.
Comment by Garry Roseman (sitquietly) - Monday, 05 May 2014, 18:04 GMT
p.s. of course I verified that the binaries produced in fact do not link to libicu.
Comment by Evangelos Foutras (foutrelis) - Tuesday, 06 May 2014, 07:57 GMT

Loading...