Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40180 - [xfce4-power-manager] Power manager fails to launch at XFCE login; requires re-launch without daemon

Attached to Project: Arch Linux
Opened by David Rosenstrauch (darose) - Thursday, 01 May 2014, 22:54 GMT
Last edited by Evangelos Foutras (foutrelis) - Friday, 07 November 2014, 05:37 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

The upgrade to v 1.2.0.198.g76d1f4f-1 fixed  FS#39893  (yay!) but caused another problem. When I log in to an XFCE session, xfce4-power-manager doesn't start up and show the power icon. (Or perhaps it starts up and then crashes.) When I then try to start it up manually it still hangs and/or crashes. The only way I'm able to successfully run the power manager (and show the icon) is to manually launch it in non-daemon mode ("xfce4-power-manager --no-daemon") after I'm logged in.

Can anyone else confirm? Any idea on cause/fix?
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Friday, 07 November 2014, 05:37 GMT
Reason for closing:  Works for me
Additional comments about closing:  Reopen if it reappears.
Comment by Evangelos Foutras (foutrelis) - Thursday, 01 May 2014, 23:16 GMT
What locale do you use? Could be an issue with a translation file.
Comment by David Rosenstrauch (darose) - Friday, 02 May 2014, 02:50 GMT
[darose@daroseneo ~]$ grep -v "^#" /etc/locale.gen
en_US.UTF-8 UTF-8
Comment by David Rosenstrauch (darose) - Friday, 02 May 2014, 14:22 GMT
Hmmm .... working today. I wonder if some recent package upgrade might have fixed this. Let me keep an eye on this for another couple of days. I'll report back if I see it again, else you can close.
Comment by David Rosenstrauch (darose) - Sunday, 04 May 2014, 17:14 GMT
Nope, definitely not fixed and still an issue. This happened again today. Though the issue does seem to be intermittent.

Power manager auto-started (in daemon mode). Never saw any icon, and eventually the power manager process terminated. Tried to start power manager (in daemon mode) manually, but same behavior. Then restarted power manager in no-daemon mode and all was well.

Not sure what the issue is. But I'll be happy to help try to debug if you have suggestions.
Comment by Evangelos Foutras (foutrelis) - Wednesday, 07 May 2014, 09:07 GMT
Could you test if the newer 1.2.0.212.g75107db-1 snapshot (in [extra]) works any better?
Comment by David Rosenstrauch (darose) - Wednesday, 07 May 2014, 13:35 GMT
Will test out today.

BTW, might have found out some more info about the problem. It seems like it starts correctly when the computer is plugged in to AC power at boot, but fails when I boot on battery power. Trying to confirm this, but figured I'd give you my early suspicion.
Comment by David Rosenstrauch (darose) - Thursday, 08 May 2014, 02:41 GMT
Hmmm ... I upgraded to the latest, but the powermanager still didn't auto-start, and I had to restart it manually in non-daemon mode. Didn't seem to make any difference whether I was on battery or AC power.

Sounds like this needs to get reported upstream. Will open a bug when I have a moment. (Or if you already know of one that's open, please post.
Comment by Pablo Lezaeta (Jristz) - Wednesday, 02 July 2014, 19:47 GMT
Was reported upstream but as I'm reading they need manpower.
The beter is try using the latest git and try fix the bug heer and sbmit the patch to upstream, they need manpower more than ever.
Comment by David Rosenstrauch (darose) - Wednesday, 09 July 2014, 17:49 GMT
Would you have a link to the upstream bug report?
Comment by Pablo Lezaeta (Jristz) - Monday, 28 July 2014, 21:01 GMT
http://git.xfce.org/xfce/xfce4-settings/commit/?id=4b89e20c97a3cf526aca831fe384f53db1c1691c

This commit say that Upower 0.99 is now supported, maybe update to the latest git again for xfce4-power-manager AND aply that commit into xfce4-settings too?
Comment by Evangelos Foutras (foutrelis) - Tuesday, 28 October 2014, 18:11 GMT
Status with xfce4-power-manager 1.4.1-2?
Comment by David Rosenstrauch (darose) - Friday, 07 November 2014, 03:39 GMT
Hmmmm .... I guess I haven't noticed this still being an issue.

I guess I'd vote to close unless someone else chimes in that they're still experiencing the problem.

Loading...