Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40060 - [system-config-printer] Add new .pyc files in package cause conflicts

Attached to Project: Arch Linux
Opened by Nicolas (alkino) - Thursday, 24 April 2014, 07:06 GMT
Last edited by Eric Belanger (Snowman) - Saturday, 26 April 2014, 17:03 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Eric Belanger (Snowman)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Problems with the version 1.4.4-1

When you install version 1.4.3-2 you got some .pyc files:
$ tar tvf system-config-printer-1.4.3-2-x86_64.pkg.tar.xz | grep ".pyc$" | wc -l
> 7

With version 1.4.4-1:
$ tar tvf system-config-printer-1.4.4-1-x86_64.pkg.tar.xz | grep ".pyc$" | wc -l
> 73

So as those .pyc heve been generated, it causes conflicts. And if I'm correct it's useless to put it in packages ;)

Can we remove it?
This task depends upon

Closed by  Eric Belanger (Snowman)
Saturday, 26 April 2014, 17:03 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Thursday, 24 April 2014, 07:08 GMT
They are not useless. If they're not included, python will create them on your filesystem whenever possible, causing untracked files. This is what happened on your system.

Also, if you run an application as regular user without .pyc/.pyo files, python will try to compile them which fails as it has no write permissions. This slows down python a lot.
Comment by Doug Newgard (Scimmia) - Thursday, 24 April 2014, 13:35 GMT
Orphan, assigning to last two packagers.

Loading...