Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40003 - [zeitgeist] 0.9.14-2 breaks empathy and gnome-contacts

Attached to Project: Arch Linux
Opened by Artem Hluvchynskyi (excieve) - Tuesday, 22 April 2014, 09:33 GMT
Last edited by Jan Alexander Steffens (heftig) - Tuesday, 22 April 2014, 15:19 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
Recent package upgrade from 0.9.14-1 to 0.9.14-2 makes at least empathy and gnome-contacts segfault.

Messages like this appear in syslog when trying to open Empathy:

10:23:02 excieve org.freedesktop.Telepathy.Client.Empathy.Chat[1093]: ** (empathy-chat:2451): WARNING **: sql.vala:350: db-reader.vala:307: SQL error: 1, near ")": syntax error
10:23:02 excieve org.freedesktop.Telepathy.Client.Empathy.Chat[1093]: ** (empathy-chat:2451): WARNING **: sql.vala:350: db-reader.vala:307: SQL error: 1, near ")": syntax error
10:23:02 excieve org.freedesktop.Telepathy.Client.Empathy.Chat[1093]: (empathy-chat:2451): GLib-CRITICAL **: g_variant_ref: assertion 'value->ref_count > 0' failed
10:23:02 excieve org.freedesktop.Telepathy.Client.Empathy.Chat[1093]: (empathy-chat:2451): GLib-CRITICAL **: g_variant_unref: assertion 'value->ref_count > 0' failed
10:23:02 excieve org.freedesktop.Telepathy.Client.Empathy.Chat[1093]: (empathy-chat:2451): GLib-CRITICAL **: g_variant_unref: assertion 'value->ref_count > 0' failed
10:23:02 excieve org.freedesktop.Telepathy.Client.Empathy.Chat[1093]: (empathy-chat:2451): folks-WARNING **: Error preparing persona store 'eds:1381192558.898.17@excieve': Couldn't open address book ‘1381192558.898.17@excieve’: Unable to connect to 'Contacts': The connection is closed
10:23:02 excieve org.freedesktop.Telepathy.Client.Empathy.Chat[1093]: (empathy-chat:2451): folks-WARNING **: Error preparing persona store 'eds:1381191422.898.5@excieve': Couldn't open address book ‘1381191422.898.5@excieve': Couldn't open address book ‘1381191422.898.5@excieve’: Unable to connect to 'Contacts': The connection is closed
10:23:02 excieve org.freedesktop.Telepathy.Client.Empathy.Chat[1093]: (empathy-chat:2451): folks-WARNING **: Error preparing persona store 'eds:1381191525.898.11@excieve': Couldn't open address book ‘181191525.898.11@excieve': Couldn't open address book ‘1381191525.898.11@excieve’: Unable to connect to 'Contacts': The connection is closed
10:23:02 excieve org.freedesktop.Telepathy.Client.Empathy.Chat[1093]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.

Similar log goes for gnome-contacts.

Downgrading to zeitgeist-0.9.14-1 solves the problem.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Tuesday, 22 April 2014, 15:19 GMT
Reason for closing:  Fixed
Additional comments about closing:  zeitgeist 0.9.15-1
Comment by Peter Weber (hoschi) - Tuesday, 22 April 2014, 09:49 GMT
I can confirm this. While reading through the changes of zeitgeist:
https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/zeitgeist&id=c42d3374fa2c08b8295d6d505f6eb577dd8c57b4
https://bugs.freedesktop.org/show_bug.cgi?id=75036

Probably the stuff written against the Vala-Binding failed silently in the past and now hits an other or older bug - because it actually works now?

Other sources (German):
https://bbs.archlinux.de/viewtopic.php?pid=322128
Comment by Jan de Groot (JGC) - Tuesday, 22 April 2014, 10:41 GMT
Please check zeitgeist 0.9.14-3. The query generator is broken with Vala 0.24, I added a fix for that.
Comment by Peter Weber (hoschi) - Tuesday, 22 April 2014, 10:51 GMT
Thank you! I will give it a try today afternoon (CET). Looks like the official-mirror needs some time to catch up with you :-)
# it serving currently the old one:
http://ftp.archlinux.org/extra/os/x86_64/zeitgeist-0.9.14-2-x86_64.pkg.tar.xz
Comment by Artem Hluvchynskyi (excieve) - Tuesday, 22 April 2014, 10:54 GMT
Empathy seems to be working at a first glance (starts up, connects fine). But gnome-contacts still segfaults as well as folks-inspect.

$ gnome-contacts

(gnome-contacts:11035): GLib-CRITICAL **: g_variant_ref: assertion 'value->ref_count > 0' failed

(gnome-contacts:11035): GLib-CRITICAL **: g_variant_unref: assertion 'value->ref_count > 0' failed
Segmentation fault (core dumped)

$ folks-inspect
>
(folks-inspect:10987): GLib-CRITICAL **: g_variant_ref: assertion 'value->ref_count > 0' failed

(folks-inspect:10987): GLib-CRITICAL **: g_variant_ref: assertion 'value->ref_count > 0' failed

(folks-inspect:10987): GLib-CRITICAL **: g_variant_unref: assertion 'value->ref_count > 0' failed

(folks-inspect:10987): GLib-CRITICAL **: g_variant_ref: assertion 'value->ref_count > 0' failed

(folks-inspect:10987): GLib-CRITICAL **: g_variant_unref: assertion 'value->ref_count > 0' failed

(folks-inspect:10987): GLib-CRITICAL **: g_variant_ref: assertion 'value->ref_count > 0' failed
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.

(folks-inspect:10987): GLib-CRITICAL **: g_variant_unref: assertion 'value->ref_count > 0' failed
Comment by Peter Weber (hoschi) - Tuesday, 22 April 2014, 15:05 GMT
I've installed "zeitgeist 0.9.14-3" and it still fails, as described by excieve.
# attached what was printed to STDOUT

Loading...