Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40001 - [pulseaudio] Service file missing, esp for headless systems

Attached to Project: Arch Linux
Opened by Kai Hendry (hendry) - Tuesday, 22 April 2014, 05:15 GMT
Last edited by Jan Steffens (heftig) - Saturday, 27 September 2014, 20:42 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Jan Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Pulseaudio is not started unless `pulseaudio --start` is started. There seems to be no canonical way to do this. For example https://wiki.archlinux.org/index.php/PulseAudio#Running recommends doing it in .xinitrc or something like that, which doesn't make sense on headless systems.


Additional info:
* 5.0-1


Steps to reproduce:
Boot a headless machine.
This task depends upon

Closed by  Jan Steffens (heftig)
Saturday, 27 September 2014, 20:42 GMT
Reason for closing:  Won't implement
Comment by Jan Steffens (heftig) - Tuesday, 22 April 2014, 15:17 GMT
There isn't. Headless set up can be tricky. You need to set up a user for PA, .pa script loading the modules you need and a service file for launching it, sorta like:

[Unit]
Description=PulseAudio Server

[Service]
User=pulse
Environment=PULSE_RUNTIME_PATH=/run/pulse
Environment=PULSE_CONFIG_PATH=/var/lib/pulse
Environment=PULSE_STATE_PATH=/var/lib/pulse
ExecStart=/usr/bin/pulseaudio --fail --disallow-module-loading --disallow-exit --exit-idle-time=-1 -n --file=/etc/pulse/headless.pa


Ensure that /run/pulse and /var/lib/pulse exist with the right modes (systemd-tmpfiles). Note that "system mode" isn't used as AFAIK it just duplicates systemd's functionality here.
Comment by Kai Hendry (hendry) - Sunday, 27 April 2014, 07:08 GMT

Loading...