Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#3999 - xorg-clients 7.0-1 empty package

Attached to Project: Pacman
Opened by Travis Willard (Cerebral) - Saturday, 18 February 2006, 16:13 GMT
Last edited by Aaron Griffin (phrakture) - Friday, 29 December 2006, 17:40 GMT
Task Type Bug Report
Category
Status Closed
Assigned To Aaron Griffin (phrakture)
Architecture not specified
Severity Critical
Priority Normal
Reported Version 0.7.1 Noodle
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The new xorg-clients package in the testing repo is totally empty, removing many utilities. Has this been broken up into seperate packages?

$ ls -l xorg-clients-*
-rw-r--r-- 1 root root 1.8M 2006-01-09 18:29 xorg-clients-6.9.0-2.pkg.tar.gz
-rw-r--r-- 1 root root 403 2006-02-18 10:59 xorg-clients-7.0-1.pkg.tar.gz
$ pacman -Qpl xorg-clients-7.0-1.pkg.tar.gz
$

Edit by Jan de Groot:
Judd, could you look into pacman for this. See one of the last comments about what we think is happening here.
Re-assigning as critical. I want this solved in either pacman2 or pacman3, these things shouldn't happen anymore. More bugreports are open for this one.
This task depends upon

Closed by  Aaron Griffin (phrakture)
Wednesday, 31 January 2007, 16:26 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in CVS - see last comment
Comment by Jan de Groot (JGC) - Saturday, 18 February 2006, 16:23 GMT
Read the frontpage announcement about it. If you didn't install it without dependency checking, this empty package should pull in all old ones.
Comment by Travis Willard (Cerebral) - Saturday, 18 February 2006, 16:25 GMT
I installed it with a normal -Syu, and yeah, I see how it's been split now.

However, glxinfo, glxgears, xev, and xkill at least are all confirmed missing. http://bbs.archlinux.org/viewtopic.php?p=143421#143421
Comment by Jan de Groot (JGC) - Saturday, 18 February 2006, 16:29 GMT
Is xorg-utils installed?
Comment by Travis Willard (Cerebral) - Saturday, 18 February 2006, 16:41 GMT
Okay, I did some playing around:

I checked if xorg-utils was installed. It was. I did a listing (pacman -Ql xorg-utils) and it said /usr/bin/xev was part of the package. I though "weird" and did ls -l /usr/bin/xev -- the file didn't exist!

So, I force-reinstalled xorg-utils; lo and behold, xev has appeared again, as has xkill. However, glxinfo and glxgears are still missing.

So, I checked the dependancies for xorg-clients. I (pacman -Rd)'d every package that xorg-clients pulls down, and then (pacman -S)'d them all back. glxinfo and glxgears are still missing however. :(
Comment by Jan de Groot (JGC) - Saturday, 18 February 2006, 16:54 GMT
Seems we have hit the pacman-doesn't-like-file-moves-bug again :(

About glxgears and glxinfo: I tracked them down to the missing MesaDemos source found at mesa3d.sf.net. The package is added to testing as mesa-apps, but since the database hasn't been rebuilt yet, it will not appear on FTP yet.
Comment by Travis Willard (Cerebral) - Saturday, 18 February 2006, 16:59 GMT
Okay, I see what happened with the files from xorg-utils et. al... Those packages were upgraded before xorg-clients, installing their files, and then when xorg-clients was upgraded, it removed those files (since it thought they were still a part of that package) and then installed the new, empty, package.

You probably already knew that, but I figured I'd say it for the benefit of anyone else reading the bug report that didn't read the frontpage news first. :P

I just checked the file listings of all the packages installed before xorg-clients was upgraded, though, and can't find any that are supposed to install the glx* files.
Comment by Travis Willard (Cerebral) - Saturday, 18 February 2006, 17:00 GMT
Oops, you snuck in there before I managed to post my comment... :) Thanks for the swift resolution, JGC!
Comment by Roman Kyrylych (Romashka) - Saturday, 11 November 2006, 17:33 GMT
See also this bug report: http://bugs.archlinux.org/task/5775
Comment by Aaron Griffin (phrakture) - Friday, 29 December 2006, 17:37 GMT
Is this still a valid bug?
Comment by Jan de Groot (JGC) - Friday, 29 December 2006, 17:39 GMT
Haven't noticed the bug with pacman3, so I guess this is fixed in pacman3.
Comment by Travis Willard (Cerebral) - Wednesday, 31 January 2007, 15:54 GMT
I can confirm it being fixed. For those of you with scientific minds I'll describe my test procedure for you to poke holes in. ;)

I just build a couple of dummy 'test' packages, test1 and test2, that simulated the 'file moving between packages' bug noted here.
I performed my tests both with pacman -U and with pacman -S using a local gensync'd repo.

test1 pkgver1: contains the file /test1.txt, with contents "This file is owned by test1"
test2 pkgver1: contains the file /test1.txt, with contents "This file is owned by test2"
test1 pkgver2: contains only the file /test2.txt, and depends on test2

So, essentially, I installed test1 pkgver1, then "upgraded" to test1 pkgver2, which pulled in the test2 dependency. The file /test1.txt in this example "moved" from test1 to test2 in this upgrade - this is the behaviour I assumed in the bug report that was causing the problems.

After installing test1 pkgver2, _both_ files /test1.txt and /test2.txt properly exist in the filesystem, and the contents of /test1.txt are "This file is owned by test2" - a successful upgrade!

For those of you who I've confused with this description, here's some console output:

$ pacman -S test1
resolving dependencies... done.
looking for inter-conflicts... done.

Targets: test1-1-1
Total Package Size: 0.1 MB

Proceed with installation? [Y/n]
checking package integrity... done.
cleaning up... done.
(1/1) checking for file conflicts [#################################################################################]100%

$ pacman -Q test1
test1 1-1

$ pacman -Ql test1
test1 test1.txt

$ cat /test1.txt
This file belongs to test1!

#UPDATE THE REPO TO pkver2

$ pacman -Su
:: Starting full system upgrade...
resolving dependencies... done.
looking for inter-conflicts... done.

Targets: test2-1-1 test1-1-2
Total Package Size: 0.1 MB

Proceed with installation? [Y/n]
checking package integrity... done.
cleaning up... done.
(2/2) checking for file conflicts [#################################################################################]100%

$ pacman -Q test1 test2
test1 1-2
test2 1-1

$ pacman -Ql test1 test2
test1 test2.txt
test2 test1.txt

$ cat /test1.txt
This file belongs to test2!

Seems like the bug is dead, folks.

Loading...