Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39989 - [cinnamon] power applet needs to patched to use upower 0.99 API

Attached to Project: Community Packages
Opened by Claire Farron (clfarron4) - Monday, 21 April 2014, 13:52 GMT
Last edited by Laurent Carlier (lordheavy) - Saturday, 26 April 2014, 18:41 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Alexandre Filgueira (faidoc)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 13
Private No

Details

Description: Power Applet and Power Settings in Cinnamon Settings need to be patched to work with upower 0.99 after the API change.

One should look at [1] and [2] for files to change.

[1] usr/lib/cinnamon-settings/modules/cs_power.py
[2] usr/share/cinnamon/applets/power@cinnamon.org/

This is not a bug with upower, as discussed in [3]

[3] https://bugs.archlinux.org/task/39876

Running "cinnamon-settings power" returns following:

cinnamon-settings power
Python module

** (cinnamon-settings.py:27008): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Could not find bluetooth module; is the cinnamon-control-center package installed?
Loading Power module
/usr/bin/python2: symbol lookup error: /usr/lib/cinnamon-control-center-1/panels/libpower.so: undefined symbol: up_client_get_can_hibernate

Package versions: claire ~ % pacman -Q cinnamon
cinnamon 2.2.3-3
claire ~ % pacman -Q upower
upower 0.99.0-2

Additional Information: GNOME Shell changes for upower 0.99 - https://git.gnome.org/browse/gnome-shell/commit/?h=gnome-3-12&id=0b8c0c202e2aaa89d5adc7427c5e4e1e37f61371

uPower API changes - http://lists.freedesktop.org/archives/devkit-devel/2013-October/001519.html

This task depends upon

Closed by  Laurent Carlier (lordheavy)
Saturday, 26 April 2014, 18:41 GMT
Reason for closing:  Upstream
Additional comments about closing:  https://github.com/linuxmint/Cinnamon/is sues/3068
Comment by Balló György (City-busz) - Monday, 21 April 2014, 23:57 GMT
It's an upstream task, please follow the discussion on the upstream issue:
https://github.com/linuxmint/Cinnamon/issues/3070
Comment by Claire Farron (clfarron4) - Saturday, 26 April 2014, 17:43 GMT
Yupyup, you are right.

This looks to be a specific thread for it: https://github.com/linuxmint/Cinnamon/issues/3068

Loading...