Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39975 - [nouveau-dri] flash/libvdpau_nouveau.so* freezes system

Attached to Project: Arch Linux
Opened by Michael Kogan (Photon) - Sunday, 20 April 2014, 11:59 GMT
Last edited by Laurent Carlier (lordheavy) - Monday, 13 October 2014, 16:54 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

Trying to open a flash video when running the nouveau driver freezes the whole system. Deleting/moving away the files /usr/lib/vdpau/libvdpau_nouveau.so* solves the problem.

Additional info:
* package version: nouveau-dri 10.1-1
* config: Geforce 7600GT, but other cards of this generation are also affected.


Steps to reproduce:

Open a flash video in any browser. Additional information in https://bbs.archlinux.org/viewtopic.php?pid=1406170
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Monday, 13 October 2014, 16:54 GMT
Reason for closing:  Upstream
Comment by Andreas Radke (AndyRTR) - Sunday, 20 April 2014, 17:18 GMT
@Laurent: maybe we should split out buggy libvdpau_nouveau.so* until they work properly.
Comment by Michael Kogan (Photon) - Monday, 21 April 2014, 16:53 GMT
I think, they are not buggy, it's just that the GeForce 7xxx series didn't support VDPAU, the GeForce 8xxx series was the first to support it. Therefore VDPAU should not be bundled with the nouveau driver (or maybe one could do two packages, one for newer cards including VDPAU and one for older cards not including VDPAU).
Comment by Tarqi Kazan (Tarqi) - Wednesday, 23 April 2014, 01:10 GMT
Same problem here (G73M [GeForce Go 7600] (rev a1)), happens some weeks/months ago. Thanks to this bugreport, I'm able to use flash again. However, splitting the package may be a good workaround, but I think it should simply not crash. Voted.
Comment by Alexey (f3ath) - Thursday, 01 May 2014, 20:19 GMT
Same issue with GK107GLM [Quadro K2000M] (rev a1). Deleting the so* helps. Thanks Michael.
Comment by Laurent Carlier (lordheavy) - Sunday, 18 May 2014, 03:42 GMT
  • Field changed: Category (Packages: Extra → Upstream Bugs)
Have you filled a bug upstream ?
Comment by Michael Kogan (Photon) - Sunday, 18 May 2014, 05:44 GMT
No, actually, I think, it's a matter of packaging. The GeForce 7xxx doesn't support VDPAU so I don't see what can be done upstream.
Comment by Laurent Carlier (lordheavy) - Sunday, 18 May 2014, 12:57 GMT
It's upstream to disable vdpau for problematic chipsets, or fix the bug. It can't be done easily at packaging level.
Comment by Michael Kogan (Photon) - Sunday, 18 May 2014, 13:59 GMT
I just asked on the Nouveau IRC channel and a dev told me that the problem is known and the only fix for now is to not use VDPAU on GeForce 7xxx cards. I think, a good solution will be to fix the Flash default settings to not use VDPAU. Should this bug be addressed to the flashplugin package then?
Comment by mattia (nTia89) - Monday, 19 May 2014, 12:14 GMT
No issue here (9800gt) as reported in the above mentioned thread
Comment by Michael Kogan (Photon) - Monday, 19 May 2014, 12:55 GMT
That's because the problem appears only with GeForce 7xxx series (and maybe earlier generations). ;)
Comment by Laerten Berjerack (Laerten) - Tuesday, 12 August 2014, 10:04 GMT
I have a Nvidia GeForce 8400GS and lately i have the same problem.
Comment by Laurent Carlier (lordheavy) - Monday, 13 October 2014, 16:53 GMT
Now vdpau drivers are in the mesa-vdpau package. It doesn't fix the problem bug now there is a proper workaround.

So i close it as an Upstream Bug.

Loading...