Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39964 - [thunar-archive-plugin] doesn't work with file-roller 3.12

Attached to Project: Arch Linux
Opened by mattia (nTia89) - Saturday, 19 April 2014, 17:24 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 23 April 2014, 17:41 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:

with the new 3.12 file-roller thunar-archive-plugin doesn't work anymore.
I get this error:

"Failed to extract files.
No suitable archive manager found."

Additional info:
* thunar-archive-plugin-0.3.1-3
* file-roller-3.12.1-1

Steps to reproduce:

try to extract an archive using the right-click menu in thunar
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 23 April 2014, 17:41 GMT
Reason for closing:  Fixed
Additional comments about closing:  thunar-archive-plugin 0.3.1-4
Comment by IMBJR (IMBJR) - Saturday, 19 April 2014, 20:00 GMT
I'm also seeing this. I've examined the tap file for file-roller (usr/lib/xfce4/thunar-archive-plugin/file-roller.tap) and even tried altering it to no effect.

As a stop-gap measure, I've created a new action to perform:

file-roller %f --extract-to=%d

and that works.
Comment by Milhail Bulash (mike_roll) - Tuesday, 22 April 2014, 18:16 GMT
Here's a workaround:

# ln -s /usr/share/applications/{org.gnome.FileRoller.desktop,file-roller.desktop}
$ xdg-mime default file-roller.desktop 'application/zip'

Simply renaming the file would do the trick, but I went the safest route
Comment by mattia (nTia89) - Wednesday, 23 April 2014, 08:10 GMT
I confirm, that workaround works! thank you @mike_roll
Comment by mattia (nTia89) - Wednesday, 23 April 2014, 08:10 GMT
I confirm, that workaround works! thank you @mike_roll
Comment by IMBJR (IMBJR) - Wednesday, 23 April 2014, 17:13 GMT
@mike_roll, I cannot get your workaround to work. I cannot apply "Extract Here" to .gz files.

I've also tried:
$ xdg-mime default file-roller.desktop 'application/x-gzip'

where application/x-gzip is apparently the MIME type for .gz files, at least according to:
http://www.hansenb.pdx.edu/DMKB/dict/tutorials/mime_typ.php

I've tried:
# cp file-roller.desktop FileRoller.desktop

and when that did not work:
# mv FileRoller.desktop org.gnome.FileRoller.desktop

My /usr/share/applications/mineinfo.cache file contains the following:
...
application/x-gzip=org.gnome.FileRoller.desktop;
...
that's why I mv from FileRoller.desktop to org.gnome.FileRoller.desktop

org.gnome.FileRoller.desktop contains the appropriate MIME type too:
... application/x-gtar;application/x-gzip;application/x-gzpostscript; ...

Loading...