Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39943 - [box2d] makedepends is missing subversion, build fails either way

Attached to Project: Community Packages
Opened by Roman Neuhauser (roman-neuhauser) - Friday, 18 April 2014, 16:22 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Monday, 21 April 2014, 12:49 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

==> Retrieving sources...
-> Updating v2.3.1 svn repo...
/usr/bin/makepkg: line 717: svn: command not found
==> WARNING: Failure while updating v2.3.1 svn repo
==> Validating source files with md5sums...
v2.3.1 ... Skipped
==> Extracting sources...
-> Creating working copy of v2.3.1 svn repo...
==> Starting build()...
/home/roman/wc/MINE/home:roman-neuhauser:arch-community/box2d/PKGBUILD: line 18: cd: /home/roman/wc/MINE/home:roman-neuhauser:arch-community/box2d/src/v2.3.1/Box2D: No such file or directory
==> ERROR: A failure occurred in build().
Aborting...

after patching, i get

==> Making package: box2d 2.3.1-1 (Fri Apr 18 18:21:57 CEST 2014)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Installing missing dependencies...
resolving dependencies...
looking for inter-conflicts...

Packages (3): cmake-2.8.12.2-2 doxygen-1.8.6-1 subversion-1.8.8-1

Total Installed Size: 73.42 MiB

:: Proceed with installation? [Y/n]
(3/3) checking keys in keyring [#####################################] 100%
(3/3) checking package integrity [#####################################] 100%
(3/3) loading package files [#####################################] 100%
(3/3) checking for file conflicts [#####################################] 100%
(3/3) checking available disk space [#####################################] 100%
(1/3) installing cmake [#####################################] 100%
Optional dependencies for cmake
qt4: cmake-gui
(2/3) installing doxygen [#####################################] 100%
Optional dependencies for doxygen
graphviz: for caller/callee graph generation
qt4: for doxywizard
(3/3) installing subversion [#####################################] 100%
Optional dependencies for subversion
libgnome-keyring: for GNOME Keyring for auth credentials
kdeutils-kwallet: for KWallet for auth credentials
bash-completion: for svn bash completion
python2: for some hook scripts [installed]
java-environment: for Java support
ruby: for some hook scripts [installed]
==> Retrieving sources...
-> Cloning v2.3.1 svn repo...
svn: E000101: Unable to connect to a repository at URL 'http://box2d.googlecode.com/svn/tags/v2.3.1'
svn: E000101: Error running context: Network is unreachable
==> ERROR: Failure while downloading v2.3.1 svn repo

which is interesting, because the url is accessible outside of makepkg.
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Monday, 21 April 2014, 12:49 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in svn
Comment by Doug Newgard (Scimmia) - Saturday, 19 April 2014, 02:43 GMT
Builds fine here after adding subversion to makedeps.

Loading...