Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39912 - [zathura-pdf-mupdf] shows blank screen

Attached to Project: Community Packages
Opened by Carl Mueller (cmlr) - Wednesday, 16 April 2014, 23:10 GMT
Last edited by Sergej Pupykin (sergej) - Thursday, 17 April 2014, 10:46 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Daniel Wallace (gtmanfred)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: With the update to zathura-pdf-mupdf 0.2.6-2, it just shows a blank gray screen. I get the following error:

carl@Bernoulli ~/Downloads $ zathura i6198.pdf
error: could not load plugin /usr/lib/zathura/pdf.so (/usr/lib/zathura/pdf.so: undefined symbol: js_isboolean)
error: unknown file type


Additional info:
* package version(s) 0.2.6-2
* config and/or log files etc.


Steps to reproduce: Try to view a pdf file with zathura.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Thursday, 17 April 2014, 10:46 GMT
Reason for closing:  Fixed
Comment by Moritz Lipp (mlq) - Thursday, 17 April 2014, 10:36 GMT
The reason behind this is that mupdf 1.4 has its own javascript interpreter which is maintained in a seperate repository, but shipped with the source code as a thirdparty lib. Since there has not been a versioned release of it yet and as far as I know mujs is developed especially for mupdf, the most convinient solution would be to add a:

install -Dm644 build/release/libmujs.a "$pkgdir"/usr/lib

to the PKGBUILD of mupdf.

Then one needs to recompile the zathura-pdf-mupdf plugin and link it against mujs as well. This can be achieved by modifying the build function to:

make -C "${srcdir}/$pkgname-$pkgver" MUPDF_LIB="-lmupdf -lmujs"

Loading...