Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39874 - [cinnamon] Latest round of updates break various features of Cinnamon

Attached to Project: Community Packages
Opened by Claire Farron (clfarron4) - Tuesday, 15 April 2014, 12:23 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 15 April 2014, 15:50 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 22
Private No

Details

Description: 1) None of the GTK, Font or Icon themes are being applied in Cinnamon settings. My suspicion is they are being overridden by the GNOME 3.12 settings because it looks like the GNOME default themes, font and icon sets (most definitely the Cantarell font (GNOME default) is being applied, because I have the Segoe set in Cinnamon, but Cantarell is being used).

2) Media keys no longer work with applications like Banshee or VLC. The media keys do work in MATE.

3) Going to "Settings" > "Keyboard" doesn't work, and now I'm stuck with using a US keyboard layout, when I had it set to use the English (GB) layout before the upgrade. EDIT: Even changing this in dconf-editor doesn't work. It seems that this is controlled by GNOME as well (this is conjecture).

4) Settings (like default terminal, text editor) have been completely written over. Further, I have set the default terminal in Cinnamon to be terminator, but the Crtl + Alt + T key combination is not loading it (I suspect trying to load gnome-terminal, which I don't have installed). However, it seems like the other Default Applications (Music Player, Text Editor, Video Player, Browser) have been preserved.

There are others as well

Additional info:
Please see the discussion on the BBS - https://bbs.archlinux.org/viewtopic.php?pid=1404665

Steps to reproduce:
Update to current repositories (both "stable" and "testing" branches are affected)
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 15 April 2014, 15:50 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#39871 
Comment by Claire Farron (clfarron4) - Tuesday, 15 April 2014, 14:51 GMT
Ok with the following update, it appears (on my system) that (1), (2) and (4) have been resolved to how they were with Cinnamon 2.0:

[2014-04-15 14:48] [PACMAN] Running 'pacman -Syu'
[2014-04-15 14:48] [PACMAN] synchronizing package lists
[2014-04-15 14:48] [PACMAN] starting full system upgrade
[2014-04-15 14:49] [PACMAN] upgraded cinnamon-settings-daemon (2.0.8-6 -> 2.2.1-1)
[2014-04-15 14:49] [PACMAN] upgraded cinnamon-control-center (2.0.9-2 -> 2.2.3-1)
[2014-04-15 14:49] [PACMAN] upgraded cinnamon-session (2.2.0-1 -> 2.2.0-2)
[2014-04-15 14:49] [PACMAN] upgraded nemo (2.2.0-1 -> 2.2.0-2)

(3) still remains (apparently, one user on the BBS is stuck with Turkish...).
Comment by Claire Farron (clfarron4) - Tuesday, 15 April 2014, 14:59 GMT
With this, my keyboard setting are now fixed and changeable:

[2014-04-15 15:54] [PACMAN] upgraded cinnamon (2.2.3-1 -> 2.2.3-2)

Waiting for confirmation on BBS thread from other users that issues are resolved.

@tasqa: We have the following thread for the Power Management stuff - https://bugs.archlinux.org/task/39876
Comment by Tako Marks (tasqa) - Tuesday, 15 April 2014, 15:48 GMT
Since I'm using cinnamon for power settings. I've noticed these aren't applied as well. Found out my laptop died on battery whilst it should have gone to sleep.
Anyone else having these symptoms?

Loading...