Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39850 - [linux] System crash with kernel 3.14 and radeon driver (drm)

Attached to Project: Arch Linux
Opened by Matthias (zap_42) - Monday, 14 April 2014, 16:38 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 19 June 2014, 06:12 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:

After upgrade to linux-3.14-5, when booting into graphical multiuser mode (gdm), the system stops working and ends up showing a kernel trace.
I was able, though, to boot into the maintenance console mode and successfully downgraded to some 3.13 kernel version...

Here's the call stack information I relocated in the logs:

Apr 13 23:18:06 renard kernel: BUG: unable to handle kernel paging request at ffffebe000000000
Apr 13 23:18:06 renard kernel: IP: [<ffffffff81188846>] kfree+0x56/0x190
Apr 13 23:18:06 renard kernel: PGD 0
Apr 13 23:18:06 renard kernel: Oops: 0000 [#1] PREEMPT SMP
Apr 13 23:18:06 renard kernel: Modules linked in: bnep bluetooth 6lowpan_iphc fuse joydev hid_logitech_dj hid_generic arc4 mousedev hp_wmi sparse_keymap uvcvideo videobuf2_vmalloc videobuf2_memops usbhid videobuf2_core videodev hid media microcode ath9k radeon ath9k_common ath9k_hw evdev mac_hid psmouse serio_raw pcspkr ir_lirc_codec ttm lirc_dev ath edac_core drm_kms_helper k10temp ir_mce_kbd_decoder edac_mce_amd snd_hda_codec_idt ir_sanyo_decoder mac80211 snd_hda_codec_generic ir_sony_decoder ir_jvc_decoder ir_rc6_decoder snd_hda_codec_hdmi drm ir_rc5_decoder ir_nec_decoder i2c_piix4 r8168(O) snd_hda_intel hwmon i2c_algo_bit cfg80211 rc_rc6_mce snd_hda_codec i2c_core snd_hwdep snd_pcm snd_timer r8169 snd rfkill soundcore jmb38x_ms ene_ir rc_core mii memstick thermal wmi hp_accel lis3lv02d input_polldev shpchp video
Apr 13 23:18:06 renard kernel: battery ac button acpi_cpufreq processor nfs lockd sunrpc fscache loop kvm_amd kvm ext4 crc16 mbcache jbd2 sd_mod sr_mod crc_t10dif cdrom crct10dif_common atkbd libps2 ahci libahci ohci_pci ehci_pci ohci_hcd ehci_hcd usbcore usb_common firewire_ohci libata scsi_mod sdhci_pci sdhci led_class mmc_core firewire_core crc_itu_t i8042 serio
Apr 13 23:18:06 renard kernel: CPU: 1 PID: 289 Comm: Xorg Tainted: G O 3.14.0-5-ARCH #1
Apr 13 23:18:06 renard kernel: Hardware name: Hewlett-Packard HP Pavilion dv7 Notebook PC/363A, BIOS F.13 01/25/2010
Apr 13 23:18:06 renard kernel: task: ffff880213ae5850 ti: ffff8800defe6000 task.ti: ffff8800defe6000
Apr 13 23:18:06 renard kernel: RIP: 0010:[<ffffffff81188846>] [<ffffffff81188846>] kfree+0x56/0x190
Apr 13 23:18:06 renard kernel: RSP: 0018:ffff8800defe7a50 EFLAGS: 00010286
Apr 13 23:18:06 renard kernel: RAX: ffffebe000000000 RBX: 0000000000000202 RCX: 0000000000000000
Apr 13 23:18:06 renard kernel: RDX: ffffea0000000000 RSI: 00000000000071bc RDI: 0000000000000202
Apr 13 23:18:06 renard kernel: RBP: ffff8800defe7a68 R08: 0000000000000021 R09: 0000000000000020
Apr 13 23:18:06 renard kernel: R10: 0000000000000002 R11: 0000000000000000 R12: ffff8802133cdc00
Apr 13 23:18:06 renard kernel: R13: ffffffffa0ae19fc R14: ffff8800dbdc0000 R15: 0000000000000000
Apr 13 23:18:06 renard kernel: FS: 00007faeeb620880(0000) GS:ffff88021fd00000(0000) knlGS:0000000000000000
Apr 13 23:18:06 renard kernel: CS: 0010 DS: 0000 ES: 0000 CR0: 000000008005003b
Apr 13 23:18:06 renard kernel: CR2: ffffebe000000000 CR3: 000000020f2e5000 CR4: 00000000000007e0
Apr 13 23:18:06 renard kernel: Stack:
Apr 13 23:18:06 renard kernel: ffff8800dbdc0000 ffff8802133cdc00 ffff8802133cd400 ffff8800defe7b48
Apr 13 23:18:06 renard kernel: ffffffffa0ae19fc ffff8800defe7ad8 ffff8800dbdc0000 ffff8800defe7ac0
Apr 13 23:18:06 renard kernel: 0000040000007810 ffff8800da0b5300 000000000000e728 0000000000000000
Apr 13 23:18:06 renard kernel: Call Trace:
Apr 13 23:18:06 renard kernel: [<ffffffffa0ae19fc>] r600_hdmi_setmode+0x64c/0x910 [radeon]
Apr 13 23:18:06 renard kernel: [<ffffffff814daadd>] ? _raw_spin_unlock_irqrestore+0x2d/0x30
Apr 13 23:18:06 renard kernel: [<ffffffffa0ab3349>] ? radeon_irq_kms_enable_afmt+0x59/0x70 [radeon]
Apr 13 23:18:06 renard kernel: [<ffffffffa0ae21a0>] ? r600_hdmi_enable+0x170/0x310 [radeon]
Apr 13 23:18:06 renard kernel: [<ffffffffa0afbc28>] radeon_atom_encoder_mode_set+0x158/0x2d0 [radeon]
Apr 13 23:18:06 renard kernel: [<ffffffffa097aa98>] drm_crtc_helper_set_mode+0x498/0x500 [drm_kms_helper]
Apr 13 23:18:06 renard kernel: [<ffffffffa0aa5b95>] radeon_property_change_mode.isra.1+0x35/0x40 [radeon]
Apr 13 23:18:06 renard kernel: [<ffffffffa0aa5d2e>] radeon_connector_set_property+0x18e/0x300 [radeon]
Apr 13 23:18:06 renard kernel: [<ffffffffa083f0f2>] drm_mode_obj_set_property_ioctl+0x142/0x340 [drm]
Apr 13 23:18:06 renard kernel: [<ffffffffa083f320>] drm_mode_connector_property_set_ioctl+0x30/0x40 [drm]
Apr 13 23:18:06 renard kernel: [<ffffffffa082eb82>] drm_ioctl+0x4f2/0x620 [drm]
Apr 13 23:18:06 renard kernel: [<ffffffff811608a3>] ? handle_mm_fault+0x853/0xea0
Apr 13 23:18:06 renard kernel: [<ffffffff814de5b4>] ? __do_page_fault+0x2b4/0x5a0
Apr 13 23:18:06 renard kernel: [<ffffffffa0a8004e>] radeon_drm_ioctl+0x4e/0x90 [radeon]
Apr 13 23:18:06 renard kernel: [<ffffffff811b6180>] do_vfs_ioctl+0x2e0/0x4c0
Apr 13 23:18:06 renard kernel: [<ffffffff811a68c1>] ? __sb_end_write+0x31/0x60
Apr 13 23:18:06 renard kernel: [<ffffffff811b63e1>] SyS_ioctl+0x81/0xa0
Apr 13 23:18:06 renard kernel: [<ffffffff814e2f69>] system_call_fastpath+0x16/0x1b
Apr 13 23:18:06 renard kernel: Code: 00 00 00 80 ff 77 00 00 48 01 d8 48 0f 42 15 e2 a7 68 00 48 01 d0 48 ba 00 00 00 00 00 ea ff ff 48 c1 e8 0c 48 c1 e0 06 48 01 d0 <48> 8b 10 80 e6 80 0f 85 d8 00 00 00 49 89 c2 49 8b 02 a8 80 0f
Apr 13 23:18:06 renard kernel: RIP [<ffffffff81188846>] kfree+0x56/0x190
Apr 13 23:18:06 renard kernel: RSP <ffff8800defe7a50>
Apr 13 23:18:06 renard kernel: CR2: ffffebe000000000
Apr 13 23:18:07 renard kernel: r8169 0000:09:00.0 eth0: link up
Apr 13 23:18:07 renard kernel: IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Apr 13 23:18:31 renard kernel: BUG: soft lockup - CPU#0 stuck for 22s! [kworker/0:0:4]
Apr 13 23:18:31 renard kernel: Modules linked in: bnep bluetooth 6lowpan_iphc fuse joydev hid_logitech_dj hid_generic arc4 mousedev hp_wmi sparse_keymap uvcvideo videobuf2_vmalloc videobuf2_memops usbhid videobuf2_core videodev hid media microcode ath9k radeon ath9k_common ath9k_hw evdev mac_hid psmouse serio_raw pcspkr ir_lirc_codec ttm lirc_dev ath edac_core drm_kms_helper k10temp ir_mce_kbd_decoder edac_mce_amd snd_hda_codec_idt ir_sanyo_decoder mac80211 snd_hda_codec_generic ir_sony_decoder ir_jvc_decoder ir_rc6_decoder snd_hda_codec_hdmi drm ir_rc5_decoder ir_nec_decoder i2c_piix4 r8168(O) snd_hda_intel hwmon i2c_algo_bit cfg80211 rc_rc6_mce snd_hda_codec i2c_core snd_hwdep snd_pcm snd_timer r8169 snd rfkill soundcore jmb38x_ms ene_ir rc_core mii memstick thermal wmi hp_accel lis3lv02d input_polldev shpchp video
Apr 13 23:18:31 renard kernel: battery ac button acpi_cpufreq processor nfs lockd sunrpc fscache loop kvm_amd kvm ext4 crc16 mbcache jbd2 sd_mod sr_mod crc_t10dif cdrom crct10dif_common atkbd libps2 ahci libahci ohci_pci ehci_pci ohci_hcd ehci_hcd usbcore usb_common firewire_ohci libata scsi_mod sdhci_pci sdhci led_class mmc_core firewire_core crc_itu_t i8042 serio
Apr 13 23:18:31 renard kernel: CPU: 0 PID: 4 Comm: kworker/0:0 Tainted: G O 3.14.0-5-ARCH #1
Apr 13 23:18:31 renard kernel: Hardware name: Hewlett-Packard HP Pavilion dv7 Notebook PC/363A, BIOS F.13 01/25/2010
Apr 13 23:18:31 renard kernel: Workqueue: events __net_random_once_deferred
Apr 13 23:18:31 renard kernel: task: ffff8802140e9d70 ti: ffff880214140000 task.ti: ffff880214140000
Apr 13 23:18:31 renard kernel: RIP: 0010:[<ffffffff810d9b02>] [<ffffffff810d9b02>] generic_exec_single+0x52/0x70
Apr 13 23:18:31 renard kernel: RSP: 0018:ffff880214141c08 EFLAGS: 00000202
Apr 13 23:18:31 renard kernel: RAX: 00000000000600f6 RBX: ffffffff811b6dd6 RCX: 0000000000000000
Apr 13 23:18:31 renard kernel: RDX: 00000000000008fb RSI: 00000000000000fb RDI: 0000000000000282
Apr 13 23:18:31 renard kernel: RBP: ffff880214141c20 R08: ffffffff818be808 R09: 0000000000000000
Apr 13 23:18:31 renard kernel: R10: dff75206e97ec900 R11: 0000000000000293 R12: ffffffff81097d32
Apr 13 23:18:31 renard kernel: R13: ffff880214141b78 R14: 0000000000000001 R15: 0000000000000001
Apr 13 23:18:31 renard kernel: FS: 00007f883e4dc700(0000) GS:ffff88021fc00000(0000) knlGS:0000000000000000
Apr 13 23:18:31 renard kernel: CS: 0010 DS: 0000 ES: 0000 CR0: 000000008005003b
Apr 13 23:18:31 renard kernel: CR2: 0000000001651068 CR3: 000000020f1f3000 CR4: 00000000000007f0
Apr 13 23:18:31 renard kernel: Stack:
Apr 13 23:18:31 renard kernel: 0000000000000001 0000000000000000 ffffffff818be800 ffff880214141c90
Apr 13 23:18:31 renard kernel: ffffffff810d9c15 ffffffff810b0340 ffff8802140e9dd8 0000000000000000
Apr 13 23:18:31 renard kernel: 0000000000000000 ffffffff8101c2e0 0000000000000000 0000000000000003
Apr 13 23:18:31 renard kernel: Call Trace:
Apr 13 23:18:31 renard kernel: [<ffffffff810d9c15>] smp_call_function_single+0xf5/0x1b0
Apr 13 23:18:31 renard kernel: [<ffffffff810b0340>] ? cpuacct_charge+0x50/0x60
Apr 13 23:18:31 renard kernel: [<ffffffff8101c2e0>] ? arch_unregister_cpu+0x30/0x30
Apr 13 23:18:31 renard kernel: [<ffffffff8101c2e0>] ? arch_unregister_cpu+0x30/0x30
Apr 13 23:18:31 renard kernel: [<ffffffff810da024>] smp_call_function_many+0x224/0x270
Apr 13 23:18:31 renard kernel: [<ffffffff813e05a0>] ? secure_ip_id+0x10/0x80
Apr 13 23:18:31 renard kernel: [<ffffffff8101c2e0>] ? arch_unregister_cpu+0x30/0x30
Apr 13 23:18:31 renard kernel: [<ffffffff813e05a1>] ? secure_ip_id+0x11/0x80
Apr 13 23:18:31 renard kernel: [<ffffffff810da09a>] smp_call_function+0x2a/0x50
Apr 13 23:18:31 renard kernel: [<ffffffff810da0e3>] on_each_cpu+0x23/0x80
Apr 13 23:18:31 renard kernel: [<ffffffff813e05a0>] ? secure_ip_id+0x10/0x80
Apr 13 23:18:31 renard kernel: [<ffffffff813e05a1>] ? secure_ip_id+0x11/0x80
Apr 13 23:18:31 renard kernel: [<ffffffff8101caab>] text_poke_bp+0x5b/0xc0
Apr 13 23:18:31 renard kernel: [<ffffffff813e05a0>] ? secure_ip_id+0x10/0x80
Apr 13 23:18:31 renard kernel: [<ffffffff81019c0c>] arch_jump_label_transform+0x8c/0x100
Apr 13 23:18:31 renard kernel: [<ffffffff811322ef>] __jump_label_update+0x5f/0x80
Apr 13 23:18:31 renard kernel: [<ffffffff811323ad>] jump_label_update+0x9d/0xb0
Apr 13 23:18:31 renard kernel: [<ffffffff811327c8>] static_key_slow_inc+0x88/0xb0
Apr 13 23:18:31 renard kernel: [<ffffffff813faf8d>] __net_random_once_deferred+0x2d/0x40
Apr 13 23:18:31 renard kernel: [<ffffffff810801f7>] process_one_work+0x167/0x420
Apr 13 23:18:31 renard kernel: [<ffffffff81080bb1>] worker_thread+0x121/0x3a0
Apr 13 23:18:31 renard kernel: [<ffffffff81080a90>] ? manage_workers.isra.23+0x2a0/0x2a0
Apr 13 23:18:31 renard kernel: [<ffffffff81087182>] kthread+0xd2/0xf0
Apr 13 23:18:31 renard kernel: [<ffffffff810870b0>] ? kthread_create_on_node+0x180/0x180
Apr 13 23:18:31 renard kernel: [<ffffffff814e2ebc>] ret_from_fork+0x7c/0xb0
Apr 13 23:18:31 renard kernel: [<ffffffff810870b0>] ? kthread_create_on_node+0x180/0x180
Apr 13 23:18:31 renard kernel: Code: 4e 01 00 48 89 de 48 03 04 d5 80 df 8b 81 48 89 df 48 89 c2 e8 50 0d 1b 00 84 c0 75 1c 45 85 e4 75 09 eb 0d 0f 1f 44 00 00 f3 90 <f6> 43 20 01 75 f8 5b 41 5c 41 5d 5d c3 90 44 89 ef ff 15 f7 9e
Apr 13 23:18:32 renard kernel: [sched_delayed] sched: RT throttling activated



This task depends upon

Closed by  Tobias Powalowski (tpowa)
Thursday, 19 June 2014, 06:12 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.15.x-1
Comment by sekret (sekret) - Monday, 14 April 2014, 17:21 GMT
I guess it's not caused by the radeon driver, since I use it as well and don't have any issues with 3.14-5
Comment by Matthias (zap_42) - Monday, 14 April 2014, 20:18 GMT
I only experience the crash when the monitor that usually serves me as primary display is attached via HDMI (after upgrading from 3.13.8-1 to 3.14-5). Using the notebook's display only provides me with a workaround.

Debian seems to have a similar issue with its linux-image-3.13-1-amd64 package: https://lists.debian.org/debian-kernel/2014/03/msg00117.html (N.B. it's the 3.13 kernel...). Regrettably, I did not find further information in the Debian thread...


Comment by korn36 (korn36) - Sunday, 11 May 2014, 13:36 GMT
This does also happen for me, on both stock arch kernel and linux-ck-k10.
The 3.13 version of both stock kernel and linux-ck-k10 does not appear to have this issue.
My GPU is ATI Radeon HD 4650.
Comment by Matthias (zap_42) - Monday, 26 May 2014, 20:35 GMT
Seems to be no problem (fixed?) with kernel 3.15.0-1-mainline, if the monitor is being attached on the running system, but not during startup!
Comment by Matthias (zap_42) - Thursday, 19 June 2014, 05:15 GMT
Fixed with linux 3.15.1-1! :-)

Loading...