Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#3985 - Unable to anonymously mmap (DVD)

Attached to Project: Arch Linux
Opened by Andrea Cimitan (Cimi) - Thursday, 16 February 2006, 22:02 GMT
Last edited by Judd Vinet (judd) - Thursday, 22 June 2006, 17:21 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture not specified
Severity Critical
Priority Normal
Reported Version 0.7.1 Noodle
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I've found this bug writing 4GB DVD. K3b stops with this error

-----------------------
K3b Version: 0.12.12

KDE Version: 3.5.1
QT Version: 3.3.5
Kernel: 2.6.16-rc3
Devices

[...]

Size of filesystem calculated: 2296251

growisofs: 6.1

growisofs
-----------------------
:-( unable to anonymously mmap 67108864: Resource temporarily unavailable
-----------------------
[...]

The only change to burn is to launch "ulimit -l unlimited" from superuser and then burn with root...
tested kernels: 2.6.15, 2.6.15.2, 2.6.16-rc3
Tested k3b: 0.12.11, 0.12.12.

Surely with debian and this hardware month ago the burn process worked (the last dvd burned...)

Using "testing".
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Friday, 23 June 2006, 22:26 GMT
Reason for closing:  Fixed
Comment by Andrea Cimitan (Cimi) - Thursday, 16 February 2006, 22:30 GMT
Tested K3b 0.12.9 (Old pkgbuild)
The bugs doesn't reproduce...

(Now compiling 0.12.10..., waiting feedback from you)
Comment by Andrea Cimitan (Cimi) - Thursday, 16 February 2006, 23:02 GMT
Yes, it's a 0.12.11-12 issue.
With 0.12.10 or 0.12.9 it doesn't reproduce.

It's a k3b archlinux bug?
Comment by Shahrazie Zainal (dragonajie) - Friday, 17 February 2006, 23:09 GMT
same problem here, using 0.12.12-1.
Comment by Luke McCarthy (shaurz) - Saturday, 18 February 2006, 19:37 GMT
Same problem here.

k3b 0.12.12-1
dvd+rw-tools 6.1-1
Comment by Simon Morgan (sjmorgan) - Monday, 20 February 2006, 11:59 GMT
I'm just double checking because it's not 100% clear. You say the problem goes away when you set ulimit -l unlimited? If this is the case can somebody else please confirm this. As for not being able to burn as a non-root user, is this because you haven't added yourself to the optical group?
Comment by Andrea Cimitan (Cimi) - Monday, 20 February 2006, 12:06 GMT
The problem appeares in k3b version 0.12.11 and the following (0.12.12).
I have the permission to burn as a normal user and I'm already added to optical group: in fact I'm able to burn with success simple CDs or Small DVDs.

The only change to burn big DVDs (for example 4GB of data or video) is to launch 'ulimit -l unlimited' from root and then to run k3b as root.
I'm not able to use 'ulimit -l unlimited' as a normal user (it gives me permission denied) so the only chance is to run k3b as root after setting 'ulimit -l unlimited'.

But as I and you know this tip isn't a fixing but only a temporaneous workaround.
Comment by Simon Morgan (sjmorgan) - Monday, 20 February 2006, 12:45 GMT
Then it's not a bug but rather a difference of opinion between Arch and k3b about what constitutes a sane max locked memory value. Those settings are there to prevent rogue programs from hogging system resources and the fact that Debian seems to disregard it is not a good thing IMHO. It could just be increased to accomodate k3b but what happens when another program comes along which doesn't work without it being increased again? I know for a fact that it's possible to burn DVDs without increasing it because I've done it with growisofs with no problems.
Comment by Shahrazie Zainal (dragonajie) - Friday, 24 February 2006, 10:57 GMT
Is there any solution for this yet? i tried Cimi's method to no avail.. :(
Comment by Andrea Cimitan (Cimi) - Friday, 24 February 2006, 12:18 GMT
Other solution is to set buffer manually to 30Mb (Configure K3b menu)
Comment by av (xirus) - Monday, 20 March 2006, 14:21 GMT
same problem with 0.12.14 :(
using the ulimit -l unlimited trick and increasing the buffer helps luckily
Comment by Luke McCarthy (shaurz) - Monday, 20 March 2006, 18:34 GMT
Andrea's solution seems to be the best (since it works for normal users). k3b shouldn't try to use so much memory at once.
Comment by Leslie Polzer (skypher) - Thursday, 23 March 2006, 10:35 GMT
NOTABUG? Arch should come with sensible ulimit settings. If people need more, they can take care of it.
Comment by Tobias Powalowski (tpowa) - Monday, 27 March 2006, 15:08 GMT
is this still happening in 2.6.16?
Comment by Tobias Powalowski (tpowa) - Monday, 27 March 2006, 15:25 GMT
the problem should be fixed in 0.12.13 already according to k3b homepage
Comment by Tobias Powalowski (tpowa) - Tuesday, 23 May 2006, 15:27 GMT
is this one still a vaild bug or can it be closed?
Comment by Tobias Powalowski (tpowa) - Tuesday, 06 June 2006, 22:00 GMT
closed due to not responding
Comment by Judd Vinet (judd) - Thursday, 22 June 2006, 17:21 GMT
Re-opened by Francois Jooste:

For the first time ever with k3b on Arch, I now get this error with 0.12.15-1.
Comment by Tobias Powalowski (tpowa) - Thursday, 22 June 2006, 17:30 GMT
could you try if loading capability module does help to get rid of this issue?
Comment by Francois Jooste (FJ) - Friday, 23 June 2006, 22:22 GMT
The problem is now fixed. I don't need to run with a mnaual buffer. Thanks. I withdraw my request to reopen.

Loading...