Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39816 - {bugtracker} password length in bugs.archlinux.org

Attached to Project: Arch Linux
Opened by sekret (sekret) - Friday, 11 April 2014, 11:15 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Sunday, 12 June 2016, 10:00 GMT
Task Type Bug Report
Category Web Sites
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

For passwords, I use a method, which generates passwords for me. Those passwords are very long (>50) and e.g. bbs and aur accept it without problems, but here on bugs.archlinux.org it doesn't work. Right now I use a temporary password, which I want to replace asap.

Is there a limit for how long the password is allowed to be? Maybe this info was in the mail I got after registering here, in that case sorry for the noise. But to me it looks more like there's a limit which isn't mentioned anywhere.
This task depends upon

Closed by  BartÅ‚omiej Piotrowski (Barthalion)
Sunday, 12 June 2016, 10:00 GMT
Reason for closing:  Not a bug
Comment by Peter Weber (hoschi) - Friday, 11 April 2014, 14:48 GMT
You should keep in mind, that this may depend on a specific database-setup. The best way to check this out, is by doing it yourself with "bisect". Take the half length and test. If it works, it could be longer. If not, shorter...and so on. Therefore, I don't think this deserved "Severity High" :-)

min seems to be 5:
http://flyspray.org/changelog#changes3

max. is probably 40:
https://github.com/Flyspray/flyspray/blob/master/setup/upgrade/0.9.9.2/flyspray-install.xml#L889



Comment by sekret (sekret) - Friday, 11 April 2014, 15:10 GMT
Sorry for putting severity to high, I actually wanted to set it to low, no idea what went wrong in my head in that moment :D

Ok thanks Peter, I'll set the length to 41 then 40 and will see if that's the max. I actually filed this because I think the lower and upper limit should be mentioned somewhere during the process of registering.
Comment by Peter Weber (hoschi) - Friday, 11 April 2014, 15:16 GMT
> I actually filed this because I think the lower and upper limit should be mentioned somewhere during the process of registering.

Yep. You're right!
Comment by sekret (sekret) - Friday, 11 April 2014, 15:19 GMT
Ok, the maximum is 30 characters for the password.

Loading...