Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39806 - [linux] firefox freezes and crashes with kernel 3.14-4

Attached to Project: Arch Linux
Opened by patrick (potomac) - Thursday, 10 April 2014, 18:43 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 16 June 2014, 09:56 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 16
Private No

Details

Description: with kernel 3.14 firefox 28.0-1 seems to have random hangs, crashs and freezes,

the problems will occur during an intensive use of firefox ( multiple tabs, multiple downloads )


Additional info:
* package version(s) linux 3.14-4, firefox 28.0-1
* config and/or log files etc.


Steps to reproduce:

- install linux 3.14-4, firefox 28.0-1
- intensive use of firefox ( open multiple tabs, a lot of download )
- after a random time ( 15 minutes, maybe 2 hours ) firefox will hang, freeze or crash

see these links for more informations :

https://mailman.archlinux.org/pipermail/arch-dev-public/2014-April/026112.html

https://mailman.archlinux.org/pipermail/arch-dev-public/2014-April/026154.html

it seems to be an upstream bug, probably the kernel because with kernel 3.13.x I don't have this problem
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 16 June 2014, 09:56 GMT
Reason for closing:  Fixed
Comment by patrick (potomac) - Friday, 11 April 2014, 01:14 GMT
one possible solution is to rebuild linux-3.14-4 with this patch :

https://lkml.org/lkml/2014/4/8/80
Comment by Doug Newgard (Scimmia) - Friday, 11 April 2014, 03:20 GMT
  • Field changed: Severity (Medium → High)
Looks like this affects other software beside firefox, see  FS#39809 
Comment by Rowan Lewis (meow) - Friday, 11 April 2014, 07:08 GMT
Yes, it's the same issue, I don't know how both of us missed this report, sorry about that.

George and myself both applied the patch from Linus at the end of this email: https://lkml.org/lkml/2014/4/8/497

It fixed the issues we were having, although he since mentioned on IRC switching back to 3.13.8, but I think that's unrelated.
Comment by Thomas Bächler (brain0) - Friday, 11 April 2014, 07:57 GMT
For reference: This patch is available at https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=69cd9eba38867a493a043bb13eb9b33cad5f1a9a. It is also in the stable queue for 3.14.
Comment by patrick (potomac) - Friday, 11 April 2014, 09:26 GMT
I have just rebuild linux 3.14 package with this patch,

the bug seems fixed with this patch, no hangs/freezes with firefox
Comment by Thomas Bächler (brain0) - Friday, 11 April 2014, 09:36 GMT
Thanks. 3.14-5 should be in the repositories soon-ish (now + 8 hours).
Comment by Rowan Lewis (meow) - Friday, 11 April 2014, 13:47 GMT
I'm no longer convinced that the patch has resolved the issue, I've just had a series of lockups were things got so bad the machine had to be rebooted.
Comment by patrick (potomac) - Friday, 11 April 2014, 14:19 GMT
@Rowan : lockups with which software ?

firefox ?

Comment by George (gh403) - Friday, 11 April 2014, 17:08 GMT
Can confirm Rowan's reservations. That patch substantially helps with stability, but I still had issues and random crashes, mostly with high CPU loads.
Comment by Jeremy M. (jskier) - Friday, 11 April 2014, 20:18 GMT
Not sure if this is related but systemd was in bad shape (also several dbus errors) on me after several Firefox crashes on 3.14, had to hard reboot. I went back to lts kernel, after a few hours no problems so far.
Comment by patrick (potomac) - Friday, 11 April 2014, 21:00 GMT
for me the lockups with firefox are gone after applying the patch, I see no others lockup with my configuration,

the patch is designed to fix "the futex race between requeue and wake" ( commit 69cd9eba38867a493a043bb13eb9b33cad5f1a9a )

for those who have again problems despite the patch it means probably that there are another bugs further in the source code of kernel 3.14, bugs who are not necessarily related to the "futex problem",

a bisect procedure with git is a solution for a precise debugging but it's not easy ( it takes long times to compile the kernel each time )
Comment by babis (tritonas00) - Sunday, 13 April 2014, 00:14 GMT
a lot of freezes here after update to linux 3.14.0 (-4 and -5)

Program received signal SIGPIPE, Broken pipe.
[Switching to Thread 0x7fffe0aff700 (LWP 12424)]
0x00007ffff7bcdefb in send () from /usr/lib/libpthread.so.0
Comment by babis (tritonas00) - Wednesday, 16 April 2014, 15:49 GMT
with new profile there are no freezes so far.
Comment by Slater (recoherence) - Friday, 18 April 2014, 11:31 GMT
I'm getting a crash just at the moment that I disable the Shockwave Flash plugin.
Comment by Slater (recoherence) - Saturday, 19 April 2014, 15:53 GMT
My problem now seems to be just with Shockwave Flash
Comment by Slater (recoherence) - Monday, 21 April 2014, 03:29 GMT
Oops - last post was wrong. Firefox is crashing when Shockwave Flash (and all other plugins) are disabled.
Comment by jack (jackgu1988) - Wednesday, 30 April 2014, 14:34 GMT
Problem continues with Firefox 29.0-1.
Comment by AnAkkk (AnAkkk) - Wednesday, 30 April 2014, 14:38 GMT
I have the same issue. Either firefox crashes, or the system lock up and I have to use the reboot button.
Comment by patrick (potomac) - Wednesday, 30 April 2014, 16:04 GMT
I don't have these problems since the 3.14-5 kernel version ( futex patch ),

don't forget that crashes can be triggered by a faulty extension in firefox ( or a corrupt firefox profile ), you can test by running firefox without extension ( or with a new profile, firefox -p )
Comment by AnAkkk (AnAkkk) - Thursday, 01 May 2014, 09:30 GMT
I guess the system lock ups are due to systemd crash dump journaling, as it fills all my available memory. I've disabled it now (https://wiki.archlinux.org/index.php/Systemd#Disabling_application_crash_dumps_journaling).

I'm running 3.15-rc3, which should already have the patch above.
Comment by Jonas Abrahamsson (JKAbrams) - Wednesday, 14 May 2014, 08:55 GMT
I have this problem (currently on 3.14.1-1, but it's been this way through all releases about the last 8 months). Thunderbird is also affected.
Safe mode and/or new profile does not help.
The whole system also locks up often (in a few diffrent ways), perhaps related as I always run Firefox with lots of tabs.
Heavy usage triggers the crash (often a crash is triggerd by opening a heavy site, but I've failed to pinpoint it further, it's seemingly random).
More info: https://bbs.archlinux.org/viewtopic.php?id=174277
Perhaps a unrelated problem as mine is not limited to 3.14-4/Firefox 28.

Loading...