Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#3980 - subversion dependency on apr missing

Attached to Project: Arch Linux
Opened by Leonard Ritter (paniq) - Wednesday, 15 February 2006, 23:14 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture not specified
Severity High
Priority Normal
Reported Version 0.7.1 Noodle
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

latest subversion package in testing is dependent on apr-util, but apr-util has to be installed manually.

[paniq@zeitgeist mjoo]$ svn stat
svn: error while loading shared libraries: libaprutil-1.so.0: cannot open shared object file: No such file or directory
[paniq@zeitgeist mjoo]$ sudo pacman -S apr-util
installing apr-util... done.
[paniq@zeitgeist mjoo]$ svn
Type 'svn help' for usage.
This task depends upon

Closed by  arjan timmerman (blaasvis)
Saturday, 25 March 2006, 22:34 GMT
Reason for closing:  Not a bug
Comment by Judd Vinet (judd) - Wednesday, 15 February 2006, 23:25 GMT
Odd, it has both listed in the repo:

[jvinet@mars www]$ pacman -Si subversion
Repository : testing
Name : subversion
Version : 1.3.0-4
Groups : None
Provides : None
Depends On : apr apr-util db>=4.3 expat gdbm glibc libxml2 neon>=0.25.4
zlib
Conflicts With : None
Replaces : None
Size (compressed) : 4567077
Description : Replacement for CVS, another versioning system (svn)
MD5 Sum : f99e29798b2de230ab6822f71c300e27
Comment by Judd Vinet (judd) - Wednesday, 15 February 2006, 23:26 GMT
I'll try adding a version dependency, that should pull in the new apr-util.

Loading...