Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39757 - [banshee] Fails to transcode songs when copying to a media device

Attached to Project: Arch Linux
Opened by John Regan (saxindustries) - Saturday, 05 April 2014, 15:45 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 17 January 2017, 16:12 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Isenmann Daniel (ise)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

I have banshee setup to transcode files to MP3 when I copy to my iPod. I also have a flash drive with a ".is_audio_player" file setup so it's recognized as a media player in Banshee.

When I drag and drop a song in a format the players can't play (in this case FLAC), Banshee immediately responds with an error about not being able to transcode the file.

I have gst-plugins-good and gst-plugins-ugly installed, along with lame, so I should be good to go for converting to MP3.

I'm attaching the output of "banshee --debug" - I started Banshee, dragged a song to my iPod, allowed it to fail, then quit Banshee. It looks like line 299 is where you see the transcoding failures.

Other programs, like Rhythmbox work fine, so I don't think it's a bug in Gstreamer

Additional info:
* package version(s)
2.6.2-3
* config and/or log files etc.
attached


Steps to reproduce:
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 17 January 2017, 16:12 GMT
Reason for closing:  Won't fix
Additional comments about closing:  banshee removed from repos
Comment by Jan de Groot (JGC) - Sunday, 06 April 2014, 07:28 GMT
You probably also need gst-libav or whatever the ffmpeg plugin is named these days.
Comment by John Regan (saxindustries) - Sunday, 06 April 2014, 14:49 GMT
I tried installing that package, it's still not transcoding.

I've got a new log with stderr included - line 195 is around where the conversion starts. I see some Gstreamer warnings about "0.10-style raw audio caps are being created" along with some "pipeline does not run" errors, and line 214 shows a message about a general stream error.

I've also got a screenshot attached of the error message in Banshee.

-John
Comment by John Regan (saxindustries) - Sunday, 06 April 2014, 14:57 GMT
Out of curiosity, I built the banshee package without any patches (so no gstreamer-1.0 patch and no gapless playback option patch), and it successfully converted the audio. So I think it might have something to do with using gstreamer-1.0
Comment by Dan (direx) - Sunday, 06 April 2014, 16:06 GMT
I can confirm this issue. In my environment Banshee even segfaults after throwing enough transcode errors (see log).

The relevant error is probably this one:

[Error 17:59:47.514] Cannot Convert File - GStreamer encountered a general stream error.: gstbaseparse.c(3242): gst_base_parse_loop (): /GstPipeline:pipeline/GstDecodeBin:decodebin/GstFlacParse:flacparse248:
streaming stopped, reason not-linked

This is probably *not* an upstream bug, as Debian testing also has Banshee 2.6.2 with gstreamer-1.0 and transcoding is working fine there... It looks like Banshee on Arch is totally messed up :(

BTW: extra/gst-libav is installed.
Comment by John Regan (saxindustries) - Monday, 07 April 2014, 13:56 GMT
I added two patches from the Debian package and recompiled, it seems to have fixed the issue:

Don-t-use-the-new-decoded-pad-signal-of-decodebin.patch
Use-new-style-GStreamer-1.0-raw-audio-caps-in-the-WA.patch

I've got them attached here.
Comment by Francis Moreau (fmoreau) - Tuesday, 02 December 2014, 15:55 GMT
I'm seeing the same issue 8 months later... is banshee actually supported on Arch ?
Comment by Isenmann Daniel (ise) - Tuesday, 02 December 2014, 19:12 GMT
This bug was totally missed by me. I will take care this week, I should have enough time to fix this problem.
Comment by Francis Moreau (fmoreau) - Monday, 02 March 2015, 15:24 GMT
  • Field changed: Percent Complete (100% → 0%)
unfortunately I still get the same error...
Comment by Isenmann Daniel (ise) - Tuesday, 07 July 2015, 07:22 GMT
Just for information: At the moment I have too little time for Arch, I will do my best to find a solution in the next upcoming weeks.

Loading...