Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39742 - [s-nail] segfaults & coredumps on using option -L

Attached to Project: Arch Linux
Opened by Tarqi Kazan (Tarqi) - Friday, 04 April 2014, 15:28 GMT
Last edited by Gaetan Bisson (vesath) - Monday, 07 April 2014, 16:34 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
[s-nail] segfaults & coredumps on using option -L on the cmdline

* package version(s)
core/s-nail 14.6.2-1 (base)
core/linux 3.13.8-1 (base)

* config and/or log files
kernel: mail[1239]: segfault at 0 ip 0804c3ed sp bfa72f80 error 4 in mail[8048000+51000]

Steps to reproduce:
type "mail -L n" on the commandline

Notes:
the spec after "-L" doesn't matter
a .mailrc file doesn't matter
happens on i686 & x64
This task depends upon

Closed by  Gaetan Bisson (vesath)
Monday, 07 April 2014, 16:34 GMT
Reason for closing:  Fixed
Additional comments about closing:  s-nail-14.6.4-1 in [testing]
Comment by Steffen Nurpmeso (sdaoden) - Friday, 04 April 2014, 19:45 GMT
Yes, hello Tarqi,

i am sorry for the inconvenience caused by S-nail -- thank you very much for reporting this!

The problem is faulty argument parsing (so to say) of the S-nail builtin argument parser (which is used only when the native getopt(3) implementation is not BSD-alike).
I have already committed the necessary fixes (to the S-nail [master] branch).

There is another outstanding minor issues which i will look into tomorrow, after which i will release an update version of S-nail.
I blindly assume Gaetan waits with a package update until then.
Comment by Gaetan Bisson (vesath) - Saturday, 05 April 2014, 01:46 GMT
Thanks a lot Steffen. I'll wait for the new release. Cheers.
Comment by Tarqi Kazan (Tarqi) - Saturday, 05 April 2014, 02:00 GMT
Yeah, thanks from me too for the fast response. Sorry for missing this out :(
Comment by Steffen Nurpmeso (sdaoden) - Saturday, 05 April 2014, 11:31 GMT
|Sorry for missing this out :(

I'll mention you in the `NEWS' of v14.6.3!
Gaetan wrote "perfectly reproducible when running `mail -L -n`" and so i did and fixed the bug before actually reading your name in this report.
Comment by Tarqi Kazan (Tarqi) - Saturday, 05 April 2014, 22:13 GMT
That's to much honor, it just was a bug report (ashamed). Gruß aus Ddorf :)
Comment by Steffen Nurpmeso (sdaoden) - Monday, 07 April 2014, 12:58 GMT
Gruß zurück aus Darmstadt (ebenfalls Mosel-Nähe)!

(I think even Gaetan will now accept S-nail v14.6.4 for inclusion. Finally.)
Comment by Gaetan Bisson (vesath) - Monday, 07 April 2014, 16:33 GMT
Vielen Dank aus Französisch-Polynesien. :)

Loading...