Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39734 - [linux] [util-linux] - old root filesystem is not an initramfs: SUCCESS

Attached to Project: Arch Linux
Opened by Peter Weber (hoschi) - Thursday, 03 April 2014, 22:48 GMT
Last edited by Dave Reisner (falconindy) - Friday, 04 April 2014, 13:19 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Tom Gundersen (tomegun)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Hello! As requested by brain0 I open this bug report. The implementation of switch_root.c inside util-linux prints a warning caused by a check, most likely because it checks the device number and not the filesystem type.

Additional info:
* package version(s): util-linux <= 2.24.1-5 and linux >= 3.14
* discussion: https://bbs.archlinux.org/viewtopic.php?id=179422
* possible fix by falconindy: http://www.spinics.net/lists/util-linux-ng/msg09062.html


Steps to reproduce:
1. Boot system with hook "base", this is the default

Workaround:
Boot system with hook "systemd", which replaces hooks "base" and "udev", you can keep the hook "fsck" with the boot-flag "rw" (default for grub) inside your bootloader! It is also possible to remove the hook "fsck", but in this case you should change the boot-flag to "ro".

Thank you

This task depends upon

Closed by  Dave Reisner (falconindy)
Friday, 04 April 2014, 13:19 GMT
Reason for closing:  Fixed
Additional comments about closing:  Patched package in [testing]
Comment by Peter Weber (hoschi) - Friday, 04 April 2014, 07:58 GMT Comment by Thomas Bächler (brain0) - Friday, 04 April 2014, 08:10 GMT
This has been worked around by a bugfix applied in Linux 3.14-3. The real, permanent fix is the one submitted by Dave.
Comment by Dave Reisner (falconindy) - Friday, 04 April 2014, 13:16 GMT
Merged: https://github.com/karelzak/util-linux/commit/c7832fb8f122f08b10bc6712f1062295a239bd06

There's going to be a 2.24.2 some time in the near future, but I've adapted the patch for our package (needed a slight tweak for magic constants) and released util-linux-2.24.1-6 into [testing].

Loading...