Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#39711 - ISO won't boot on lenovo X230

Attached to Project: Release Engineering
Opened by Vladislav Guberinic (neosisani) - Tuesday, 01 April 2014, 14:00 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Wednesday, 09 April 2014, 23:15 GMT
Task Type Bug Report
Category Hardware Issues
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I get to choose if I want shell, archlinux or memtest. Shell boots into something. If I try archlinux I just get blank screen.
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Wednesday, 09 April 2014, 23:15 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#33745 
Comment by Vladislav Guberinic (neosisani) - Saturday, 05 April 2014, 23:49 GMT
Are you sure this is the same bug?

I already have working archlinux on same machine which works just fine. It is just that ISO doesn't work fine.

If this is duplicate of #33745, that would mean kernels on ISO and in repos are not same, right?
Comment by Gerardo Exequiel Pozzi (djgera) - Saturday, 05 April 2014, 23:51 GMT
who knows, you did not provide any detailed information, versions at least.

https://www.archlinux.org/releng/releases/
Comment by Vladislav Guberinic (neosisani) - Saturday, 05 April 2014, 23:57 GMT
ISO is version from march.

If you could tell me what information you need I might provide it. Or if there is some kernel flag you want me to pass while in syslinux(if it is syslinux)? But blank screen happens before anything is written to screen.
Comment by Doug Newgard (Scimmia) - Sunday, 06 April 2014, 04:10 GMT
The kernels on the March ISO and in the repos are not the same, one is a month old and one is current. The bug in question pops up randomly, even with micro version updates.
Comment by Gerardo Exequiel Pozzi (djgera) - Sunday, 06 April 2014, 04:42 GMT
I suggest to ask in forums for help. I guess something is broken in firmware (EFI) and needs a workaround/quirk in kernel or maybe in bootloader (gummiboot). The is nothing to do with archiso.

Loading...