Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#3970 - apache package (2.2.0-1) broken

Attached to Project: Arch Linux
Opened by Thomas B├Ąchler (brain0) - Monday, 13 February 2006, 22:19 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture not specified
Severity High
Priority Normal
Reported Version 0.7.1 Noodle
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Since the update to version 2.2.0-1, the apache package is broken:

[thomas@architect ~]$ ldd /usr/sbin/httpd
linux-gate.so.1 => (0xffffe000)
libm.so.6 => /lib/tls/libm.so.6 (0xb7ef4000)
libaprutil-1.so.0 => not found
libgdbm.so.3 => /usr/lib/libgdbm.so.3 (0xb7eee000)
libdb-4.3.so => /usr/lib/libdb-4.3.so (0xb7e1e000)
libpq.so.4 => not found
libsqlite3.so.0 => not found
libsqlite.so.0 => not found
libexpat.so.0 => /usr/lib/libexpat.so.0 (0xb7dfd000)
libapr-1.so.0 => not found
libuuid.so.1 => /lib/libuuid.so.1 (0xb7dfa000)
librt.so.1 => /lib/tls/librt.so.1 (0xb7df1000)
libcrypt.so.1 => /lib/libcrypt.so.1 (0xb7dc2000)
libpthread.so.0 => /lib/tls/libpthread.so.0 (0xb7daf000)
libdl.so.2 => /lib/libdl.so.2 (0xb7dab000)
libc.so.6 => /lib/tls/libc.so.6 (0xb7c8c000)
/lib/ld-linux.so.2 (0xb7f3a000)

My guess is that these extra libs have been added by accident (as they are not in the dependencies). I heard someone say the same about subversion (1.3.0-2), and can confirm this, too:

[thomas@architect ~]$ ldd /usr/bin/svn
linux-gate.so.1 => (0xffffe000)
libsvn_client-1.so.0 => /usr/lib/libsvn_client-1.so.0 (0xb7fa9000)
libsvn_wc-1.so.0 => /usr/lib/libsvn_wc-1.so.0 (0xb7f7f000)
libsvn_ra-1.so.0 => /usr/lib/libsvn_ra-1.so.0 (0xb7f7b000)
libsvn_diff-1.so.0 => /usr/lib/libsvn_diff-1.so.0 (0xb7f74000)
libsvn_ra_local-1.so.0 => /usr/lib/libsvn_ra_local-1.so.0 (0xb7f6e000)
libsvn_repos-1.so.0 => /usr/lib/libsvn_repos-1.so.0 (0xb7f51000)
libsvn_fs-1.so.0 => /usr/lib/libsvn_fs-1.so.0 (0xb7f4a000)
libsvn_fs_fs-1.so.0 => /usr/lib/libsvn_fs_fs-1.so.0 (0xb7f30000)
libsvn_fs_base-1.so.0 => /usr/lib/libsvn_fs_base-1.so.0 (0xb7f0b000)
libsvn_ra_svn-1.so.0 => /usr/lib/libsvn_ra_svn-1.so.0 (0xb7efa000)
libsvn_ra_dav-1.so.0 => /usr/lib/libsvn_ra_dav-1.so.0 (0xb7ee2000)
libsvn_delta-1.so.0 => /usr/lib/libsvn_delta-1.so.0 (0xb7eda000)
libsvn_subr-1.so.0 => /usr/lib/libsvn_subr-1.so.0 (0xb7eb1000)
libaprutil-1.so.0 => not found
libgdbm.so.3 => /usr/lib/libgdbm.so.3 (0xb7e8d000)
libdb-4.3.so => /usr/lib/libdb-4.3.so (0xb7dbd000)
libpq.so.4 => not found
libsqlite3.so.0 => not found
libsqlite.so.0 => not found
libapr-1.so.0 => not found
libuuid.so.1 => /lib/libuuid.so.1 (0xb7db9000)
librt.so.1 => /lib/tls/librt.so.1 (0xb7db0000)
libpthread.so.0 => /lib/tls/libpthread.so.0 (0xb7d9c000)
libneon.so.25 => /usr/lib/libneon.so.25 (0xb7d81000)
libssl.so.0.9.7 => /usr/lib/libssl.so.0.9.7 (0xb7d4f000)
libdl.so.2 => /lib/libdl.so.2 (0xb7d4b000)
libgssapi.so.4 => /usr/lib/libgssapi.so.4 (0xb7d35000)
libkrb5.so.17 => /usr/lib/libkrb5.so.17 (0xb7ced000)
libasn1.so.6 => /usr/lib/libasn1.so.6 (0xb7cba000)
libcom_err.so.2 => /lib/libcom_err.so.2 (0xb7cb7000)
libcrypto.so.0.9.7 => /usr/lib/libcrypto.so.0.9.7 (0xb7ba5000)
libroken.so.16 => /usr/lib/libroken.so.16 (0xb7b93000)
libcrypt.so.1 => /lib/libcrypt.so.1 (0xb7b65000)
libresolv.so.2 => /lib/libresolv.so.2 (0xb7b53000)
libexpat.so.0 => /usr/lib/libexpat.so.0 (0xb7b32000)
libz.so.1 => /usr/lib/libz.so.1 (0xb7b20000)
libc.so.6 => /lib/tls/libc.so.6 (0xb7a01000)
/lib/ld-linux.so.2 (0xb7fd0000)
libaprutil-1.so.0 => not found
libpq.so.4 => not found
libsqlite3.so.0 => not found
libsqlite.so.0 => not found
libapr-1.so.0 => not found
libaprutil-1.so.0 => not found
libpq.so.4 => not found
libsqlite3.so.0 => not found
libsqlite.so.0 => not found
libapr-1.so.0 => not found
libaprutil-1.so.0 => not found
libpq.so.4 => not found
libsqlite3.so.0 => not found
libsqlite.so.0 => not found
libapr-1.so.0 => not found
libaprutil-1.so.0 => not found
libpq.so.4 => not found
libsqlite3.so.0 => not found
libsqlite.so.0 => not found
libapr-1.so.0 => not found
libaprutil-1.so.0 => not found
libpq.so.4 => not found
libsqlite3.so.0 => not found
libsqlite.so.0 => not found
libapr-1.so.0 => not found
libaprutil-1.so.0 => not found
libpq.so.4 => not found
libsqlite3.so.0 => not found
libsqlite.so.0 => not found
libapr-1.so.0 => not found
libapr-1.so.0 => not found
libaprutil-1.so.0 => not found
libpq.so.4 => not found
libsqlite3.so.0 => not found
libsqlite.so.0 => not found
libapr-1.so.0 => not found
libaprutil-1.so.0 => not found
libpq.so.4 => not found
libsqlite3.so.0 => not found
libsqlite.so.0 => not found
libapr-1.so.0 => not found
libaprutil-1.so.0 => not found
libpq.so.4 => not found
libsqlite3.so.0 => not found
libsqlite.so.0 => not found
libapr-1.so.0 => not found
libaprutil-1.so.0 => not found
libpq.so.4 => not found
libsqlite3.so.0 => not found
libsqlite.so.0 => not found
libapr-1.so.0 => not found
libaprutil-1.so.0 => not found
libpq.so.4 => not found
libsqlite3.so.0 => not found
libsqlite.so.0 => not found
libapr-1.so.0 => not found
libaprutil-1.so.0 => not found
libpq.so.4 => not found
libsqlite3.so.0 => not found
libsqlite.so.0 => not found
libapr-1.so.0 => not found

(this is the original output from ldd, I have no idea why it is so long and libs are listed twice or even more often)
This task depends upon

Closed by  Judd Vinet (judd)
Wednesday, 15 February 2006, 23:30 GMT
Reason for closing:  Fixed
Comment by Leonard Ritter (paniq) - Wednesday, 15 February 2006, 23:14 GMT
this might be related to a problem with the most recent subversion upgrade.

http://bugs.archlinux.org/task/3980
Comment by Judd Vinet (judd) - Wednesday, 15 February 2006, 23:30 GMT
This should be fixed in 2.2.0-2

Loading...