Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39664 - [python2-lxml] etree.so requires libgcrypt 1.5, breaks when upgraded to libgcrypt 1.6

Attached to Project: Arch Linux
Opened by Arthur Huillet (ahuillet) - Friday, 28 March 2014, 12:12 GMT
Last edited by Felix Yan (felixonmars) - Friday, 28 March 2014, 14:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hello,

after upgrading libgcrypt to 1.6, "etree" module in python2-lxml no longer works:

Python 2.7.6 (default, Feb 26 2014, 12:01:28)
[GCC 4.8.2 20140206 (prerelease)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import lxml.etree
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
ImportError: libgcrypt.so.11: cannot open shared object file: No such file or directory

One has to install libgcrypt15 from AUR. Can something be done about this problem?

Thank you
This task depends upon

Closed by  Felix Yan (felixonmars)
Friday, 28 March 2014, 14:34 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Friday, 28 March 2014, 12:56 GMT
What version of python2-lxml do you have? Also, is your system updated to latest versions?

python2-lxml was rebuilt very recently, libgcrypt update is from one month ago.
Comment by Arthur Huillet (ahuillet) - Friday, 28 March 2014, 13:04 GMT
local/python2-lxml 3.3.3-2
local/libgcrypt 1.6.1-1

Those are the latest versions as far as I can tell.

And:

$ ldd /usr/lib/python2.7/site-packages/lxml/etree.so
[...]
libgcrypt.so.11 => /usr/lib/libgcrypt.so.11 (0xb6f8f000)
[...]

libgcrypt.so.11 is part of libcrypt15 from AUR, not part of libgcrypt 1.6.

The problem really does appear with the latest versions.
Comment by Jan de Groot (JGC) - Friday, 28 March 2014, 13:51 GMT
libgcrypt is pulled in from libexslt.so, which is part of libxslt. The current version of that lib links to libgcrypt.so.20.

Comment by Arthur Huillet (ahuillet) - Friday, 28 March 2014, 14:05 GMT
My apologies, you are correct.

Loading...