Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39652 - [abiword] saving a document as a pdf causes a crash

Attached to Project: Arch Linux
Opened by Austin Adams (ausbin) - Thursday, 27 March 2014, 21:25 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 08 April 2014, 14:25 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andreas Radke (AndyRTR)
Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Saving a document as a PDF in abiword results in a crash and a core dump.
This bug is actually known and fixed in trunk: http://bugzilla.abisource.com/show_bug.cgi?id=13586#c2
Fixing commit (r33662): http://www.abisource.com/viewvc?view=rev&revision=33662
Patch generated by viewVC (also attached): http://www.abisource.com/viewvc/abiword/trunk/src/text/fmt/gtk/fv_UnixSelectionHandles.cpp?r1=33662&r2=33661&pathrev=33662&view=patch

In order to fix the problem for myself, I modified the PKGBUILD of extra/abiword from abs as follows (also attached):

--- PKGBUILD.orig 2014-03-27 17:07:20.541797022 -0400
+++ PKGBUILD 2014-03-27 16:15:38.438464414 -0400
@@ -17,2 +17,9 @@
-source=(http://abisource.com/downloads/$pkgbase/$pkgver/source/$pkgbase-$pkgver.tar.gz)
-md5sums=('8d9c41cff3a8fbef8d0c835c65600e65')
+source=(http://abisource.com/downloads/$pkgbase/$pkgver/source/$pkgbase-$pkgver.tar.gz
+ fix-pdf-crash.patch)
+md5sums=('8d9c41cff3a8fbef8d0c835c65600e65'
+ '13e7bdc48af8a46bab1a9b637183ecd9')
+
+prepare() {
+ cd $srcdir/$pkgbase-$pkgver
+ patch -Np2 -i $srcdir/fix-pdf-crash.patch
+}

Considering that this issue is basically fixed by upstream, it may be wise to simply wait until the next release. I figured that I'd file a report anyway, though, because, in my opinion, this problem is not insignificant.
My apologies if this is off-limits for the Arch bug tracker.

Additional info:
* abiword 3.0.0-1 in extra

Steps to reproduce:
1. in an instance of abiword, go to file > save a copy
2. try to save a pdf
3. core dump
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 08 April 2014, 14:25 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.0.0-2
Comment by Austin Adams (ausbin) - Thursday, 27 March 2014, 21:29 GMT
dang, forgot to bump pkgrel. oh well, my point is made.
Comment by Doug Newgard (Scimmia) - Friday, 28 March 2014, 06:10 GMT
Orphan, assigning to the two devs that have worked on it recently.

Loading...