Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39602 - [linux] Modules for 3G mobile broadband modem not loaded

Attached to Project: Arch Linux
Opened by Maciej Sitarz (macieks2) - Sunday, 23 March 2014, 18:05 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 13 August 2014, 07:42 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After plugging in my 3G mobile broadband modem it is not detected by NetworkManager.
I compared usb-devices output when using kernel linux 3.13.6-2 and linux-lts 3.10.33-1.

It's working with linux-lts and not working with linux.

Additional info:
* package version(s)
linux 3.13.6-2
linux-lts 3.10.33-1

* config and/or log files etc.
usb-devices with kernel: linux 3.13.6-2
T: Bus=07 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 13 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=19d2 ProdID=0017 Rev=00.00
S: Manufacturer=ZTE,Incorporated
S: Product=ZTE WCDMA Technologies MSM
S: SerialNumber=P680A1ZTED010000
C: #Ifs= 5 Cfg#= 1 Atr=c0 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
I: If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
I: If#= 2 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
I: If#= 3 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
I: If#= 4 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)

usb-devices with kernel: linux-lts 3.10.33-1
T: Bus=02 Lev=02 Prnt=02 Port=00 Cnt=01 Dev#= 20 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=19d2 ProdID=0017 Rev=00.00
S: Manufacturer=ZTE,Incorporated
S: Product=ZTE WCDMA Technologies MSM
S: SerialNumber=P680A1ZTED010000
C: #Ifs= 5 Cfg#= 1 Atr=c0 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
I: If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
I: If#= 2 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
I: If#= 3 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=qmi_wwan
I: If#= 4 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 13 August 2014, 07:42 GMT
Reason for closing:  No response
Comment by Daniel Micay (thestinger) - Tuesday, 22 April 2014, 18:06 GMT
Since you've verified that this is a kernel regression, it would be nice to get it reported upstream. It would also be useful to include a list of loaded modules, and see if manually loading the missing modules works.

Loading...