Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39596 - {archweb} failed to notice certain upgrades

Attached to Project: Arch Linux
Opened by Gaetan Bisson (vesath) - Sunday, 23 March 2014, 02:47 GMT
Last edited by Dan McGee (toofishes) - Sunday, 23 March 2014, 15:15 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Dan McGee (toofishes)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Archweb believes our repos still contain libedit-20130601-1 when in fact we have upgraded to version 20140213 four days ago.

To confirm, compare `pacman -Si libedit` with https://www.archlinux.org/packages/core/x86_64/libedit/ .

I believe other packages are affected and could try to put together an exhaustive list if it helps.
This task depends upon

Closed by  Dan McGee (toofishes)
Sunday, 23 March 2014, 15:15 GMT
Reason for closing:  Fixed
Comment by Dan McGee (toofishes) - Sunday, 23 March 2014, 15:10 GMT
Knowing other packages that are out of sync would be helpful for sure.
Comment by Dan McGee (toofishes) - Sunday, 23 March 2014, 15:15 GMT
This was just bad luck. There haven't been updates to [core] since March 20th, and when it tried to update after the libedit push that day, it errored out. We only try to update the database when updates happen, and unfortunately we haven't had one since then.

I kicked one off by doing `touch /srv/ftp/core/os/*/core.files.tar.gz` on nymeria; in the future, feel free to give this method a shot. :)

Loading...