Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39585 - [python-astroid] pylint crashes when analyzing nontrivial code

Attached to Project: Arch Linux
Opened by Mathieu Pasquet (mathieui) - Saturday, 22 March 2014, 12:59 GMT
Last edited by Felix Yan (felixonmars) - Saturday, 22 March 2014, 16:55 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Angel Velasquez (angvp)
Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

When analyzing non-trivial code, pylint crashes with a traceback since python 3.4.

Additional info:
* package versions: python == 3.4.0-2, python-pylint == 1.1.0-3, python-astroid == 1.1.0-2
* See attached traceback

Steps to reproduce:

Analyze some code, e.g. with
$ pylint /usr/lib/python3.4/site-packages/pylint

Get a traceback instead of the report (with a few lines of report mixed in before the final crash).
This task depends upon

Closed by  Felix Yan (felixonmars)
Saturday, 22 March 2014, 16:55 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.0.1-3
Comment by Doug Newgard (Scimmia) - Saturday, 22 March 2014, 15:58 GMT
  • Field changed: Summary ([python-astroid] [python-pylint] pylint crashes when analyzing nontrivial code → [python-astroid] pylint crashes when analyzing nontrivial code)
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Category (Packages: Testing → Upstream Bugs)
  • Task assigned to Angel Velasquez (angvp), Felix Yan (felixonmars)

Loading...