Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39537 - [goagent] Unable to read certs

Attached to Project: Community Packages
Opened by yhy (yhylord) - Wednesday, 19 March 2014, 11:08 GMT
Last edited by Felix Yan (felixonmars) - Thursday, 20 March 2014, 12:46 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
GoAgent has no permission to get certs.Some websites shows "No Data Received",such as YouTube and GitHub.
I've added GoAgent CA to my browser.

Additional info:
* package version(s)
3.15.2
* config and/or log files etc.
# systemctl status -l goagent
Mar 20 02:52:41 localhost python2[264]: File "/usr/share/goagent/local/goagent", line 2182, in do_CONNECT
Mar 20 02:52:41 localhost python2[264]: return self.do_CONNECT_AGENT()
Mar 20 02:52:41 localhost python2[264]: File "/usr/share/goagent/local/goagent", line 2245, in do_CONNECT_AGENT
Mar 20 02:52:41 localhost python2[264]: certfile = CertUtil.get_cert(host)
Mar 20 02:52:41 localhost python2[264]: File "/usr/share/goagent/local/goagent", line 323, in get_cert
Mar 20 02:52:41 localhost python2[264]: return CertUtil._get_cert(commonname, sans)
Mar 20 02:52:41 localhost python2[264]: File "/usr/share/goagent/local/goagent", line 305, in _get_cert
Mar 20 02:52:41 localhost python2[264]: with open(certfile, 'wb') as fp:
Mar 20 02:52:41 localhost python2[264]: IOError: [Errno 13] Permission denied: 'certs/youtube.com.crt'

Steps to reproduce:
1. sudo systemctl start goagent
2. Use GoAgent in YouTube.
This task depends upon

Closed by  Felix Yan (felixonmars)
Thursday, 20 March 2014, 12:46 GMT
Reason for closing:  Not a bug
Comment by yhy (yhylord) - Wednesday, 19 March 2014, 11:11 GMT
# ls -lA /usr/share/goagent/local/certs
-rw-r--r-- 1 root root 2973 Mar 13 19:04 .ak.facebook.com.crt
-rw-r--r-- 1 root root 2969 Mar 13 19:04 .cloudfront.net.crt
-rw-r--r-- 1 root root 2961 Mar 13 19:04 .facebook.com.crt
-rw-r--r-- 1 root root 2953 Mar 13 19:04 twitter.com.crt
Comment by Felix Yan (felixonmars) - Wednesday, 19 March 2014, 15:30 GMT
Did you run goagent as root before? The mtime is at Mar 13, and the certs were not included in the package.

Please stop goagent, chown the whole certs directory back to nobody:nobody (chown -R nobody:nobody /usr/share/goagent/local/certs), and try again.
Comment by yhy (yhylord) - Thursday, 20 March 2014, 12:45 GMT
Yes...Sorry for this simple mistake.

Loading...