Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39451 - [Libreoffice] wont work without gtk2

Attached to Project: Arch Linux
Opened by daimonion (demon) - Saturday, 15 March 2014, 10:46 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 16 March 2014, 16:07 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

% loffice
Warning: failed to read path from javaldx
/usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

Since when gtk2 is hard requirement for LibreOffice?

I don't have gtk2 on my system, and until now, LibreOffice worked just fine with libreoffice-kde4 installed.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 16 March 2014, 16:07 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Saturday, 15 March 2014, 11:39 GMT
This seems to have changed with 4.2.x - We will move it back to required dependencies now.
Comment by daimonion (demon) - Saturday, 15 March 2014, 12:08 GMT
--enable-telepathy flag is what requires gtk2. I'm trying to configure and to compile LO myself (with --disable-gtk && --disable-gtk3 flags), but still cannot procede without --disable-telepathy (just to note I do have complete telepathy-kde installed):

checking whether to enable Telepathy support... yes
checking for TELEPATHY... no
configure: error: Package requirements (telepathy-glib >= 0.18.0 glib-2.0 gobject-2.0 gthread-2.0 gio-2.0 gtk+-2.0 >= 2.4 ) were not met:

No package 'gtk+-2.0' found

Also, gstreamer0.10 should be added to makedepeneds (or to build it with --disable-gstreamer-0-10):

checking whether to enable the new GStreamer 1.0 avmedia backend... yes
checking whether to enable the GStreamer avmedia backend... yes
checking for GSTREAMER_0_10... no
checking for GSTREAMER_0_10... no
configure: error: Package requirements (gstreamer-0.10 gstreamer-plugins-base-0.10 ) were not met:

No package 'gstreamer-0.10' found
No package 'gstreamer-plugins-base-0.10' found
Comment by daimonion (demon) - Saturday, 15 March 2014, 21:19 GMT
Seems the Gentoo devs reported this upstream:
https://bugs.gentoo.org/show_bug.cgi?id=461514
Comment by Andreas Radke (AndyRTR) - Sunday, 16 March 2014, 10:29 GMT
Please check 4.2.2-2 in testing with broken telepathy collaboration support disabled. Is it possible again to run it without gtk2?
Comment by daimonion (demon) - Sunday, 16 March 2014, 11:30 GMT
It works now, thanks!

Loading...