Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39440 - [hyena] build fails

Attached to Project: Community Packages
Opened by Joel Teichroeb (klusark) - Saturday, 15 March 2014, 04:15 GMT
Last edited by Balló György (City-busz) - Saturday, 15 March 2014, 12:13 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Balló György (City-busz)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

./Hyena.Data.Gui/Accessibility/ColumnCellAccessible.cs ./Hyena.Data.Gui/Accessibility/ColumnCellTextAccessible.cs ./Hyena.Data.Gui/Accessibility/ColumnHeaderCellTextAccessible.cs ./Hyena.Data.Gui/Accessibility/ICellAccessibleParent.cs ./Hyena.Data.Gui/Accessibility/ListViewAccessible.cs ./Hyena.Data.Gui/Accessibility/ListViewAccessible_Selection.cs ./Hyena.Data.Gui/Accessibility/ListViewAccessible_Table.cs ./Hyena.Data.Gui/CellContext.cs ./Hyena.Data.Gui/Column.cs ./Hyena.Data.Gui/ColumnCell.cs ./Hyena.Data.Gui/ColumnCellCheckBox.cs ./Hyena.Data.Gui/ColumnCellRating.cs ./Hyena.Data.Gui/ColumnCellText.cs ./Hyena.Data.Gui/ColumnController.cs ./Hyena.Data.Gui/ColumnHeaderCellText.cs ./Hyena.Data.Gui/DataViewChild.cs ./Hyena.Data.Gui/DataViewLayout.cs ./Hyena.Data.Gui/DataViewLayoutGrid.cs ./Hyena.Data.Gui/IHeaderCell.cs ./Hyena.Data.Gui/IInteractiveCell.cs ./Hyena.Data.Gui/IListView.cs ./Hyena.Data.Gui/ISizeRequestCell.cs ./Hyena.Data.Gui/ITextCell.cs ./Hyena.Data.Gui/ITooltipCell.cs ./Hyena.Data.Gui/ListView/ListView.cs ./Hyena.Data.Gui/ListView/ListView_Accessible.cs ./Hyena.Data.Gui/ListView/ListView_DragAndDrop.cs ./Hyena.Data.Gui/ListView/ListView_Header.cs ./Hyena.Data.Gui/ListView/ListView_Interaction.cs ./Hyena.Data.Gui/ListView/ListView_Model.cs ./Hyena.Data.Gui/ListView/ListView_Rendering.cs ./Hyena.Data.Gui/ListView/ListView_Windowing.cs ./Hyena.Data.Gui/ListView/ListViewBase.cs ./Hyena.Data.Gui/ListViewTestModule.cs ./Hyena.Data.Gui/ObjectListView.cs ./Hyena.Data.Gui/RowActivatedHandler.cs ./Hyena.Data.Gui/SortableColumn.cs ./Hyena.Gui.Canvas/Point.cs ./Hyena.Gui.Canvas/Rect.cs ./Hyena.Gui.Canvas/Size.cs ./Hyena.Gui.Canvas/Thickness.cs ./Hyena.Gui.Dialogs/ExceptionDialog.cs ./Hyena.Gui.Dialogs/VersionInformationDialog.cs ./Hyena.Gui.Theatrics/Actor.cs ./Hyena.Gui.Theatrics/Choreographer.cs ./Hyena.Gui.Theatrics/Pulsator.cs ./Hyena.Gui.Theatrics/SingleActorStage.cs ./Hyena.Gui.Theatrics/Stage.cs ./Hyena.Gui.Theatrics/Tests/ChoreographerTests.cs ./Hyena.Gui.Theming/GtkColors.cs ./Hyena.Gui.Theming/GtkTheme.cs ./Hyena.Gui.Theming/Theme.cs ./Hyena.Gui.Theming/ThemeContext.cs ./Hyena.Gui.Theming/ThemeEngine.cs ./Hyena.Gui.Theming/ThemeTestModule.cs ./Hyena.Gui/ActionManager.cs ./Hyena.Gui/BaseWidgetAccessible.cs ./Hyena.Gui/CairoDamageDebugger.cs ./Hyena.Gui/CairoExtensions.cs ./Hyena.Gui/CleanRoomStartup.cs ./Hyena.Gui/CompositeUtils.cs ./Hyena.Gui/Contrast.cs ./Hyena.Gui/DragDropList.cs ./Hyena.Gui/EditableEraseAction.cs ./Hyena.Gui/EditableInsertAction.cs ./Hyena.Gui/EditableUndoAdapter.cs ./Hyena.Gui/GtkUtilities.cs ./Hyena.Gui/GtkWorkarounds.cs ./Hyena.Gui/HyenaActionGroup.cs ./Hyena.Gui/PangoCairoHelper.cs ./Hyena.Gui/PangoExtensions.cs ./Hyena.Gui/PixbufImageSurface.cs ./Hyena.Gui/RatingRenderer.cs ./Hyena.Gui/ShadingTestWindow.cs ./Hyena.Gui/TestModuleAttribute.cs ./Hyena.Gui/TestModuleRunner.cs ./Hyena.Gui/TooltipSetter.cs ./Hyena.Query.Gui/DateQueryValueEntry.cs ./Hyena.Query.Gui/FileSizeQueryValueEntry.cs ./Hyena.Query.Gui/IntegerQueryValueEntry.cs ./Hyena.Query.Gui/NullQueryValueEntry.cs ./Hyena.Query.Gui/QueryBox.cs ./Hyena.Query.Gui/QueryDebugger.cs ./Hyena.Query.Gui/QueryLimitBox.cs ./Hyena.Query.Gui/QueryTermBox.cs ./Hyena.Query.Gui/QueryTermsBox.cs ./Hyena.Query.Gui/QueryValueEntry.cs ./Hyena.Query.Gui/RelativeTimeSpanQueryValueEntry.cs ./Hyena.Query.Gui/StringQueryValueEntry.cs ./Hyena.Query.Gui/TimeSpanQueryValueEntry.cs ./Hyena.Widgets/AnimatedBox.cs ./Hyena.Widgets/AnimatedHBox.cs ./Hyena.Widgets/AnimatedImage.cs ./Hyena.Widgets/AnimatedVBox.cs ./Hyena.Widgets/AnimatedWidget.cs ./Hyena.Widgets/ComplexMenuItem.cs ./Hyena.Widgets/EntryPopup.cs ./Hyena.Widgets/GenericToolItem.cs ./Hyena.Widgets/HigMessageDialog.cs ./Hyena.Widgets/ImageButton.cs ./Hyena.Widgets/MenuButton.cs ./Hyena.Widgets/MessageBar.cs ./Hyena.Widgets/PulsingButton.cs ./Hyena.Widgets/RatingEntry.cs ./Hyena.Widgets/RatingMenuItem.cs ./Hyena.Widgets/RoundedFrame.cs ./Hyena.Widgets/ScrolledWindow.cs ./Hyena.Widgets/SegmentedBar.cs ./Hyena.Widgets/SimpleTable.cs ./Hyena.Widgets/SmoothScrolledWindow.cs ./Hyena.Widgets/TextViewEditable.cs ./Hyena.Widgets/WrapLabel.cs
./Hyena.Data.Gui/ColumnCellText.cs(95,29): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Data.Gui/ColumnHeaderCellText.cs(39,32): warning CS0108: `Hyena.Data.Gui.ColumnHeaderCellText.DataHandler' hides inherited member `Hyena.Data.Gui.ColumnCellText.DataHandler'. Use the new keyword if hiding was intended
./Hyena.Data.Gui/ColumnCellText.cs(43,32): (Location of the symbol related to previous warning)
error CS1705: Assembly `gdk-sharp, Version=2.12.0.0, Culture=neutral, PublicKeyToken=35e10195dab3c99f' references `Mono.Cairo, Version=4.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756' which has a higher version number than imported assembly `Mono.Cairo, Version=2.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756'
./Hyena.Data.Gui/ListView/ListView_Rendering.cs(111,41): error CS0012: The type `Cairo.Context' is defined in an assembly that is not referenced. Consider adding a reference to assembly `Mono.Cairo, Version=4.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756'
/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-2.0/gdk-sharp.dll (Location of the symbol related to previous error)
./Hyena.Data.Gui/ListView/ListView_Rendering.cs(210,31): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Data.Gui/ListView/ListView_Rendering.cs(364,31): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Data.Gui/ListView/ListView_Rendering.cs(421,31): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Data.Gui/ListView/ListView_Rendering.cs(455,27): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Data.Gui/ListView/ListView_Rendering.cs(463,27): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Data.Gui/ListViewTestModule.cs(165,20): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Data.Gui/ListViewTestModule.cs(177,20): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui.Theming/GtkTheme.cs(90,27): warning CS0618: `Cairo.Context.Pattern' is obsolete: `Use GetSource/GetSource'
./Hyena.Gui.Theming/GtkTheme.cs(93,18): warning CS0618: `Cairo.Pattern.Destroy()' is obsolete: `Use Dispose()'
./Hyena.Gui.Theming/GtkTheme.cs(96,27): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui.Theming/GtkTheme.cs(123,16): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui.Theming/GtkTheme.cs(125,16): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui.Theming/GtkTheme.cs(134,20): warning CS0618: `Cairo.Context.Pattern' is obsolete: `Use GetSource/GetSource'
./Hyena.Gui.Theming/GtkTheme.cs(136,20): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui.Theming/GtkTheme.cs(174,20): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui.Theming/GtkTheme.cs(177,20): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui.Theming/GtkTheme.cs(202,16): warning CS0618: `Cairo.Context.Pattern' is obsolete: `Use GetSource/GetSource'
./Hyena.Gui.Theming/GtkTheme.cs(205,18): warning CS0618: `Cairo.Pattern.Destroy()' is obsolete: `Use Dispose()'
./Hyena.Gui.Theming/GtkTheme.cs(221,16): warning CS0618: `Cairo.Context.Pattern' is obsolete: `Use GetSource/GetSource'
./Hyena.Gui.Theming/GtkTheme.cs(225,16): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui.Theming/GtkTheme.cs(228,18): warning CS0618: `Cairo.Pattern.Destroy()' is obsolete: `Use Dispose()'
./Hyena.Gui.Theming/GtkTheme.cs(243,16): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui.Theming/GtkTheme.cs(256,16): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui.Theming/GtkTheme.cs(278,16): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui.Theming/GtkTheme.cs(283,16): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui.Theming/GtkTheme.cs(294,16): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui.Theming/GtkTheme.cs(303,16): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui.Theming/GtkTheme.cs(327,24): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui.Theming/GtkTheme.cs(340,24): warning CS0618: `Cairo.Context.Pattern' is obsolete: `Use GetSource/GetSource'
./Hyena.Gui.Theming/GtkTheme.cs(347,26): warning CS0618: `Cairo.Pattern.Destroy()' is obsolete: `Use Dispose()'
./Hyena.Gui.Theming/GtkTheme.cs(353,20): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui.Theming/GtkTheme.cs(361,20): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui.Theming/GtkTheme.cs(370,16): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui/CairoDamageDebugger.cs(52,16): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui/CairoExtensions.cs(70,34): warning CS0618: `Cairo.Context.Target' is obsolete: `Use GetTarget/SetTarget'
./Hyena.Gui/CairoExtensions.cs(70,59): warning CS0618: `Cairo.Context.Target' is obsolete: `Use GetTarget/SetTarget'
./Hyena.Gui/CairoExtensions.cs(322,30): warning CS0618: `Cairo.Context.Target' is obsolete: `Use GetTarget/SetTarget'
./Hyena.Gui/PixbufImageSurface.cs(59,36): error CS0161: `Hyena.Gui.PixbufImageSurface.Create(Gdk.Pixbuf, bool)': not all code paths return a value
./Hyena.Gui/RatingRenderer.cs(94,28): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui/RatingRenderer.cs(96,28): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui/RatingRenderer.cs(100,24): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui/ShadingTestWindow.cs(61,24): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui/ShadingTestWindow.cs(71,24): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Gui/ShadingTestWindow.cs(60,21): error CS0165: Use of unassigned local variable `cr'
./Hyena.Gui/ShadingTestWindow.cs(77,45): error CS0165: Use of unassigned local variable `cr'
./Hyena.Widgets/MessageBar.cs(141,34): error CS0165: Use of unassigned local variable `cr'
./Hyena.Widgets/MessageBar.cs(144,49): error CS0165: Use of unassigned local variable `cr'
./Hyena.Widgets/PulsingButton.cs(107,16): warning CS0618: `Cairo.Context.Pattern' is obsolete: `Use GetSource/GetSource'
./Hyena.Widgets/PulsingButton.cs(109,18): warning CS0618: `Cairo.Pattern.Destroy()' is obsolete: `Use Dispose()'
./Hyena.Widgets/PulsingButton.cs(106,13): error CS0165: Use of unassigned local variable `cr'
./Hyena.Widgets/RatingEntry.cs(269,30): error CS0165: Use of unassigned local variable `cr'
./Hyena.Widgets/RoundedFrame.cs(153,28): error CS0165: Use of unassigned local variable `cr'
./Hyena.Widgets/RoundedFrame.cs(159,49): error CS0165: Use of unassigned local variable `cr'
./Hyena.Widgets/SegmentedBar.cs(336,16): warning CS0618: `Cairo.Context.Source' is obsolete: `Use GetSource/GetSource'
./Hyena.Widgets/SegmentedBar.cs(351,20): warning CS0618: `Cairo.Context.Pattern' is obsolete: `Use GetSource/GetSource'
./Hyena.Widgets/SegmentedBar.cs(361,22): warning CS0618: `Cairo.Pattern.Destroy()' is obsolete: `Use Dispose()'
./Hyena.Widgets/SegmentedBar.cs(376,17): warning CS0618: `Cairo.Pattern.Destroy()' is obsolete: `Use Dispose()'
./Hyena.Widgets/SegmentedBar.cs(324,44): error CS0165: Use of unassigned local variable `cr'
./Hyena.Widgets/SegmentedBar.cs(327,13): error CS0165: Use of unassigned local variable `cr'
./Hyena.Widgets/SegmentedBar.cs(391,15): warning CS0618: `Cairo.Surface.Destroy()' is obsolete: `Use Dispose()'
./Hyena.Widgets/SegmentedBar.cs(415,16): warning CS0618: `Cairo.Context.Pattern' is obsolete: `Use GetSource/GetSource'
./Hyena.Widgets/SegmentedBar.cs(417,16): warning CS0618: `Cairo.Context.Pattern' is obsolete: `Use GetSource/GetSource'
./Hyena.Widgets/SegmentedBar.cs(417,24): warning CS0618: `Cairo.Pattern.Destroy()' is obsolete: `Use Dispose()'
./Hyena.Widgets/SegmentedBar.cs(424,16): warning CS0618: `Cairo.Context.Pattern' is obsolete: `Use GetSource/GetSource'
./Hyena.Widgets/SegmentedBar.cs(426,16): warning CS0618: `Cairo.Context.Pattern' is obsolete: `Use GetSource/GetSource'
./Hyena.Widgets/SegmentedBar.cs(426,24): warning CS0618: `Cairo.Pattern.Destroy()' is obsolete: `Use Dispose()'
./Hyena.Widgets/SegmentedBar.cs(443,20): warning CS0618: `Cairo.Context.Pattern' is obsolete: `Use GetSource/GetSource'
./Hyena.Widgets/SegmentedBar.cs(448,20): warning CS0618: `Cairo.Context.Pattern' is obsolete: `Use GetSource/GetSource'
./Hyena.Widgets/SegmentedBar.cs(455,16): warning CS0618: `Cairo.Context.Pattern' is obsolete: `Use GetSource/GetSource'
./Hyena.Widgets/SegmentedBar.cs(458,20): warning CS0618: `Cairo.Pattern.Destroy()' is obsolete: `Use Dispose()'
./Hyena.Widgets/SegmentedBar.cs(459,27): warning CS0618: `Cairo.Pattern.Destroy()' is obsolete: `Use Dispose()'
./Hyena.Widgets/SegmentedBar.cs(460,26): warning CS0618: `Cairo.Pattern.Destroy()' is obsolete: `Use Dispose()'
./Hyena.Widgets/SegmentedBar.cs(493,20): warning CS0618: `Cairo.Context.Pattern' is obsolete: `Use GetSource/GetSource'
./Hyena.Widgets/SegmentedBar.cs(495,20): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Widgets/SegmentedBar.cs(497,22): warning CS0618: `Cairo.Pattern.Destroy()' is obsolete: `Use Dispose()'
./Hyena.Widgets/SegmentedBar.cs(508,20): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
./Hyena.Widgets/SegmentedBar.cs(517,20): warning CS0618: `Cairo.Context.Color' is obsolete: `Use SetSourceRGBA method'
Compilation failed: 13 error(s), 68 warnings
Makefile:708: recipe for target '../bin/Hyena.Gui.dll' failed
make[1]: *** [../bin/Hyena.Gui.dll] Error 1
make[1]: Leaving directory '/build/hyena/src/hyena-0.5/Hyena.Gui'
Makefile:363: recipe for target 'all-recursive' failed
make: *** [all-recursive] Error 1
==> ERROR: A failure occurred in build().
Aborting...

Steps to reproduce:
sudo extra-x86_64-build
This task depends upon

Closed by  Balló György (City-busz)
Saturday, 15 March 2014, 12:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  hyena 0.5-4

Loading...