Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39395 - [python2-pyopenssl] 0.14-1 kills deluged

Attached to Project: Arch Linux
Opened by John (graysky) - Thursday, 13 March 2014, 22:17 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Friday, 14 March 2014, 02:35 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: Upon upgrading to 0.14-1 deluged will not start. Output attached. Downgrading to python2-pyopenssl-0.13.1-1 fixes the problem. This is confirmed on i686; no time to test x86_64.

% deluged
[ERROR ] 18:12:15 main:237 No module named six
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/deluge/main.py", line 229, in start_daemon
from deluge.core.daemon import Daemon
File "/usr/lib/python2.7/site-packages/deluge/core/daemon.py", line 45, in <module>
from deluge.core.rpcserver import RPCServer, export
File "/usr/lib/python2.7/site-packages/deluge/core/rpcserver.py", line 45, in <module>
from twisted.internet import ssl, reactor, defer
File "/usr/lib/python2.7/site-packages/twisted/internet/ssl.py", line 25, in <module>
from OpenSSL import SSL
File "/usr/lib/python2.7/site-packages/OpenSSL/__init__.py", line 8, in <module>
from OpenSSL import rand, crypto, SSL
File "/usr/lib/python2.7/site-packages/OpenSSL/rand.py", line 9, in <module>
from six import integer_types as _integer_types
ImportError: No module named six


Additional info:
* package version(s) python2-pyopenssl-0.14-1
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Friday, 14 March 2014, 02:35 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#39388 
Comment by Matthias Dienstbier (fs4000) - Thursday, 13 March 2014, 22:19 GMT
Same with gajim. It won't connect with TLS because of "missing" python2-pyopenssl.

This is a duplicate of  FS#39388 .

Loading...