Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39374 - [mesa-libgl] broken library symlinks in mesa-libgl 10.1.0-3

Attached to Project: Arch Linux
Opened by wtf (oi_wtf) - Thursday, 13 March 2014, 00:57 GMT
Last edited by Laurent Carlier (lordheavy) - Thursday, 13 March 2014, 15:29 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
The symlink /usr/lib/libEGL.so.1.1.0 in mesa-libgl is wrong.
Firstly it points to /usr/lib/mesa/libEGL.so.1.0.0 not /usr/lib/mesa/libEGL.so.1.1.0
secondly /usr/lib/libEGL.so points to libEGL.so.1.0.0 and is therefore broken.

% ls -la /lib/libEGL.so
lrwxrwxrwx 1 root root 15 12. Mär 15:03 /lib/libEGL.so -> libEGL.so.1.0.0

% ls -la /lib/libEGL.so.1.1.0
lrwxrwxrwx 1 root root 29 12. Mär 15:03 /lib/libEGL.so.1.1.0 -> /usr/lib/mesa/libEGL.so.1.0.0*

% pacman -Qo /lib/libEGL.so
/lib/libEGL.so is owned by mesa-libgl 10.1.0-3

bp@bplap:~ % pacman -Qo /lib/libEGL.so.1.1.0
/lib/libEGL.so.1.1.0 is owned by mesa-libgl 10.1.0-3

% pacman -Qo /usr/lib/mesa/libEGL.so.1.0.0
/usr/lib/mesa/libEGL.so.1.0.0 is owned by mesa 10.1.0-3

Additional info:
% pacman -Q mesa mesa-libgl intel-dri
mesa 10.1.0-3
mesa-libgl 10.1.0-3
intel-dri 10.1.0-3


Steps to reproduce:
Install packages mentioned above.
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Thursday, 13 March 2014, 15:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  mesa-10.1.0-4
Comment by Gustavo Alvarez (sl1pkn07) - Thursday, 13 March 2014, 02:29 GMT Comment by Felix Yan (felixonmars) - Thursday, 13 March 2014, 03:21 GMT
ln -s /usr/lib/mesa/libGLESv1-CM.so.1.1.0 ${pkgdir}/usr/lib/libGLESv1-CM.so.1.1.0
ln -s libGLESv1_CM.so.1.1.0 ${pkgdir}/usr/lib/libGLESv1-CM.so.1
ln -s libGLESv1_CM.so.1.1.0 ${pkgdir}/usr/lib/libGLESv1-CM.so

is wrong either, all should be using "_" instead of "-".

Loading...