Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39371 - [clutter] [nvidia] 1.16.4-3 + 334.21-2 : Screen refreshing problems with nvidia binary drivers

Attached to Project: Arch Linux
Opened by Joran Martinière (omer666) - Wednesday, 12 March 2014, 19:51 GMT
Last edited by Jan de Groot (JGC) - Thursday, 01 October 2015, 14:50 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Ionut Biru (wonder)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:

When using GNOME 3 with latest nvidia binary drivers along with latest clutter package, supposedly already including buffer-age patch, there still are screen refreshing problems.
More on this in this thread :
https://bbs.archlinux.org/viewtopic.php?id=178024

Also, most probably related :
https://bbs.archlinux.org/viewtopic.php?id=177925

Additional info:
* package version(s)

nvidia-334.21-2
nvidia-utils-334.21-3
nvidia-libgl-334.21-3
clutter-1.16.4-3

* config and/or log files etc.
-nothing relevent-

Steps to reproduce:

Install GNOME 3.10 with clutter and nvidia binary drivers.
It mostly happens in Firefox when scrolling on a web page with mousewheel without turning "Hardware Acceleration" on (in which case it doesn't happen at all), or in Transmission when browsing through several active torrents.
This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 01 October 2015, 14:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  GNOME 3.18
Comment by Doug Newgard (Scimmia) - Thursday, 13 March 2014, 01:35 GMT
Similar to  FS#39194 . Pulling in people from both packages.
Comment by Andreas Radke (AndyRTR) - Thursday, 13 March 2014, 16:37 GMT
Feel free to work with upstream to solve it. The known patch improving situation has been applied.
Comment by Sven-Hendrik Haase (Svenstaro) - Sunday, 06 April 2014, 22:44 GMT
Is this still an issue in kernel 3.14? Is this even anything we can patch/fix further than we already tried?
Comment by Wojo (Wojo) - Wednesday, 16 April 2014, 15:58 GMT
Still an issue with clutter 1.18.0-1, nvidia 337.12-1 and linux 3.14.1-1.
Comment by Hermann Zahnweh (eigengrau) - Wednesday, 16 April 2014, 18:07 GMT
I can confirm this for clutter 1.18.0. Though upstream seems to consider there might be a separate, as of yet unresolved issue which looks similar. https://bugzilla.gnome.org/show_bug.cgi?id=724788
Comment by Tim (blackout23) - Wednesday, 16 April 2014, 19:53 GMT Comment by Joran Martinière (omer666) - Saturday, 19 April 2014, 10:08 GMT
The bug proposal on mutter bugtracker is here:
https://bugzilla.gnome.org/show_bug.cgi?id=728464
Comment by Ionut Biru (wonder) - Wednesday, 23 April 2014, 21:37 GMT
can you guys try to boot up using rcutree.rcu_idle_gp_delay=1 kernel parameter?
Comment by Johan Sandelin (j0s) - Thursday, 24 April 2014, 16:00 GMT
Thanks for looking into this! Alas, that kernel parameter didn't make any difference for me.
Comment by Joran Martinière (omer666) - Thursday, 24 April 2014, 17:49 GMT
It doesn't do anything for me either.
Comment by Wojo (Wojo) - Wednesday, 30 April 2014, 15:14 GMT
Same here, didn't help
Comment by Sven-Hendrik Haase (Svenstaro) - Saturday, 31 May 2014, 16:13 GMT
Test 337.25 please.
Comment by Tim (blackout23) - Saturday, 31 May 2014, 18:09 GMT
Still have this problem. Just created a folder, tried to name it Test but only Tes showed up until I clicked inside nautilus.

https://bugzilla.gnome.org/show_bug.cgi?id=728464

The Gnome guys seem to think it's a problem in mutter and have created a couple of patches. Did not try if I can apply them against mutter 3.12 codebase to patch my package, yet.
Comment by Ionut Biru (wonder) - Saturday, 31 May 2014, 19:40 GMT
Tim, let me know if is working fine for you
Comment by Tim (blackout23) - Saturday, 31 May 2014, 22:35 GMT
The patches don't apply for most hunks and the code is much to different to manually apply them.
Comment by Joran Martinière (omer666) - Tuesday, 03 June 2014, 15:50 GMT
There hasn't been much work on these patches lately... quite disappointing...
Even patches marked ready for commit aren't committed yet. They've been accepted for commit one month ago...
Comment by Joran Martinière (omer666) - Saturday, 05 July 2014, 12:58 GMT
Hi,
It seems that there is something in the nvidia drivers preventing the GNOME team from applying their patch for the problem.
See https://bugzilla.gnome.org/show_bug.cgi?id=728464#c51

So I posted to their forums in order to know if they are working on it.
See https://devtalk.nvidia.com/default/topic/729908/linux/-gt-334-21-redrawing-problems-in-gnome-3-10-3-12-gtx-580/post/4255716/#4255716

If anyone wants to add something...
Comment by Tim (blackout23) - Thursday, 13 August 2015, 20:05 GMT
With the latest NVIDIA driver and these two patches:
https://git.gnome.org/browse/mutter/commit/?id=39763d4addd7fab1b6ab02622577413fa0228254
https://git.gnome.org/browse/mutter/commit/?id=9df6cda3e33e468d8e2ed61abdc5f21094e43ab3

This problem is finally fixed after more than a year.

A Gnome dev also backported them to 3.14 und 3.16 mutter, but he doesn't know if there will be a point release of them in the future. So it might be a good idea to ship these patches and close this bug finally. With Gnome 3.18 they can be dropped.
https://bugzilla.gnome.org/show_bug.cgi?id=728464
Comment by Sven-Hendrik Haase (Svenstaro) - Thursday, 13 August 2015, 20:14 GMT
Sweet, I'm adding heftig as he also seems to care for gnome.

Loading...