Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39368 - [cinnamon] Slow application startup

Attached to Project: Community Packages
Opened by riccardo (lionelric) - Wednesday, 12 March 2014, 17:36 GMT
Last edited by György Balló (City-busz) - Saturday, 19 April 2014, 01:08 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Alexandre Filgueira (faidoc)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 36
Private No

Details

Description: automatic start of applications is slow, about 10 seconds.

Additional info:
* package version(s) 2.0.14-3
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  György Balló (City-busz)
Saturday, 19 April 2014, 01:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  muffin 2.2.1-2
Comment by Spyros Stathopoulos (Foucault) - Friday, 14 March 2014, 09:33 GMT
The problem is probably linked to the libevdev update, since downgrading libevdev and the immediate packages that depend on it (clutter, muffin, cinnamon) seems to "solve" the issue. Since the main consumer of libevdev is clutter I suppose one could check if clutter from git has the same problem. But this entails the rebuild of the packages that depend on clutter and clutter-gtk (clutter-gtk, caribou, cinnamon, muffin, clutter-gst, mutter, and more) because clutter-git has a soname bump as well. I think that libevdev update should have been held back a bit to better coordinate with clutter.
Comment by riccardo (lionelric) - Saturday, 15 March 2014, 15:13 GMT
ok, I tried to do the downgrading of libevdev and packages that depend on it (clutter, muffins, cinnamon), but cinnamon to start in fallback mode.
I have not tried it with the git package. I think the best solution is to wait for the update of clutter and see if it fixes the bug. thank you!
Comment by Jay Little (jaylittle) - Monday, 24 March 2014, 11:09 GMT
I've attached a log file containing the journalctl data logged when cinnamon fails to start promptly. Hopefully it will be of help.
Comment by Sander de Leeuw (s.deleeuw) - Wednesday, 26 March 2014, 22:59 GMT
My biggest annoyance regarding this bug is that desktop icons are not shown immediately after cinnamon is loaded. I worked around this issue by:

---

1. Create /usr/local/bin/cinnamon-session-workaround (and make it executable)

[sander@slprobook ~]$ cat /usr/local/bin/cinnamon-session-workaround
#!/bin/sh
/usr/bin/nemo -n &
exec cinnamon-session --session cinnamon "$@"

2. Create /usr/share/xsessions/cinnamon-workaround.desktop

[sander@slprobook ~]$ cat /usr/share/xsessions/cinnamon-workaround.desktop
[Desktop Entry]
Name=Cinnamon (Workaround bug #39368)
Comment=This session logs you into Cinnamon
Exec=cinnamon-session-workaround
TryExec=/usr/bin/cinnamon
Icon=
Type=Application

3. Select session 'Cinnamon (Workaround bug #39368)' in your display manager (in my case lightdm)

---

This way, my desktop icons are displayed immediately after loggin into Cinnamon.
Hopefully the maintainers will fix this issue soon.

Sander de Leeuw
Comment by Johannes Rest (JohRest) - Tuesday, 01 April 2014, 15:50 GMT
Hi everybody,

I can confirm this on my own Home Workstation; same error messages in systemd journal.

Is there any update on why this is Happening?

Regards

Johannes
Comment by Artyom Pertsovsky (skylight) - Wednesday, 02 April 2014, 00:07 GMT
Same problem
Comment by Rafal (robin92) - Thursday, 03 April 2014, 06:37 GMT
Same here and I use Intel graphics so no nvidia related issue.

Here's a package list (concerning cinnamon & libevdev) when the issue occurs:
cinnamon 2.0.14-3
cinnamon-control-center 2.0.9-1
cinnamon-desktop 2.0.4-1
cinnamon-screensaver 2.0.3-4
cinnamon-session 2.0.6-2
cinnamon-settings-daemon 2.0.8-4
cinnamon-translations 2.0.3-1
clutter 1.16.4-3
clutter-gst 2.0.10-1
clutter-gtk 1.4.4-4
libevdev 1.1-1
muffin 2.0.5-2
xf86-input-evdev 2.8.2-2

And on the following packages, as suggested http://forum.antergos.com/viewtopic.php?f=6&t=1505, issue doesn't occur:
cinnamon 2.0.14-2
cinnamon-control-center 2.0.9-1
cinnamon-desktop 2.0.4-1
cinnamon-screensaver 2.0.3-4
cinnamon-session 2.0.6-2
cinnamon-settings-daemon 2.0.8-4
cinnamon-translations 2.0.3-1
clutter 1.16.4-1
clutter-gst 2.0.10-1
clutter-gtk 1.4.4-4
libevdev 0.6-1
muffin 2.0.5-1
xf86-input-evdev 2.8.2-2

As for Cinnamon Fallback when running Git package, my installation also started in fallback when I did reversed cinnamon but not libevdev. So it should be noted that when reverting packages, you should revert all four: cinnamon, clutter, muffin and libevdev.
Comment by Johannes Rest (JohRest) - Thursday, 03 April 2014, 08:33 GMT
I can confirm that there's no relation to nvidia, as I'm running intel graphics too...
Comment by Eicke Herbertz (WolleTD) - Thursday, 03 April 2014, 09:16 GMT
Confirmed on ATI graphics, too.
Comment by Jay Little (jaylittle) - Thursday, 03 April 2014, 11:25 GMT
Intel graphics here.
Comment by Matt (persistent) - Sunday, 06 April 2014, 09:07 GMT
Same here with ATI
Comment by Klaus Schwarz (nored) - Sunday, 06 April 2014, 10:52 GMT
nearly 30 secs here on Intel graphics
Comment by Barkowski (UncleS-A-M) - Wednesday, 09 April 2014, 14:40 GMT
Same issue with two different machines (nvidia and intel graphics).
Comment by Claire Farron (clfarron4) - Friday, 11 April 2014, 20:23 GMT
I DON'T have this problem. However, I will say that I am using MATE to provide programs like the terminal, text editor and so on. I am also using AMD Catalyst.
Comment by György Balló (City-busz) - Saturday, 12 April 2014, 14:49 GMT
Please contact with upstream. It's looks like a very mysterious bug probably caused by libevdev 0.6, and we can't fix it downstream.
Comment by sb56637 (sb56637) - Thursday, 17 April 2014, 14:04 GMT
I can confirm that this is still a bug with Cinnamon 2.2.
Comment by Michael Brunner (sm0x) - Thursday, 17 April 2014, 21:42 GMT
Comment by Claire Farron (clfarron4) - Friday, 18 April 2014, 14:07 GMT
OK, so I noticed with Cinnamon 2.2 that autostart applications were starting up slowly and I was getting the message described in the first post of this thread: https://bbs.archlinux.org/viewtopic.php?pid=1406034

@loqs suggested, after having updated the entirety of Cinnamon to rebuild muffin manually with the package libsm as a dependency, so I went ahead and did that, and voila, the problem is gone (as described in this comment of the aforementioned thread: https://bbs.archlinux.org/viewtopic.php?pid=1406034#p1406034)

So, as @loqs suggested, I think that a rebuild of muffin, with libsm as an added dependency is in order.
Comment by sb56637 (sb56637) - Friday, 18 April 2014, 15:46 GMT
@Claire: Is it just a matter of having libsm installed, or does something actually have to be changed in Muffin? Because I do have libsm installed, but still experience this bug.
Comment by Claire Farron (clfarron4) - Friday, 18 April 2014, 15:52 GMT
@sb56637: I think it should be in the makedepends rather than depends.
Comment by sb56637 (sb56637) - Friday, 18 April 2014, 15:56 GMT
@clfarron4: I see, thanks. Feel like sharing your Muffin package? I could test it if you want.
Comment by Claire Farron (clfarron4) - Friday, 18 April 2014, 16:13 GMT
https://drive.google.com/folderview?id=0B_6_fEdsgx-lWER2Ym1wVGpzdWs&usp=sharing

EDIT: You should be looking at muffin-2.2.1-1.1-x86_64.pkg.tar.xz, not 2.1.1-1 XD

I also attach the files here. You should be looking at the second of the two muffin files if you are on the x86_64 architecture and use the PKGBUILD if you are 32bit.
Comment by sb56637 (sb56637) - Friday, 18 April 2014, 16:17 GMT
Nice fix! I confirm that it works great.
Comment by Claire Farron (clfarron4) - Friday, 18 April 2014, 16:19 GMT
Thank @loq on the BBS, not me! I just so happened to build and test it because I was affected.
Comment by Jay Little (jaylittle) - Friday, 18 April 2014, 16:30 GMT
I just installed the muffin package provided by Claire and it resolved my cinnamon application startup issue. I guess it's time to get the package maintainers build environment updated, eh?

Very nice work! It's great to finally have a solution to this problem!
Comment by Claire Farron (clfarron4) - Friday, 18 April 2014, 16:44 GMT
Marked muffin for a rebuild, with the recommended changes. We'll see how things go now.
Comment by György Balló (City-busz) - Saturday, 19 April 2014, 01:07 GMT
Thanks for investigating this bug.

Loading...