Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#39262 - [rednotebook] Segfault in

Attached to Project: Arch Linux
Opened by Dan Liew (delcypher) - Monday, 10 March 2014, 11:40 GMT
Last edited by Andrea Scarpino (BaSh) - Tuesday, 18 March 2014, 11:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I use an application called Rednotebook (AUR: ) and I've noticed that it has started triggering a segfault in which is weird because Rednotebook is written in Python and AFAIK uses GTK not Qt.

Additional info:
* qt4 4.8.5-7
* rednotebook 1.8.0-1 (AUR)
* KDE 4.12.3
* I'm using kde-gtk-config to control GTK appearance is KDE

Steps to reproduce:
1. Install build and install rednotebook package from AUR
2. Run rednotebook from your terminal
3. The rednotebook GUI will appear, exit the usual way by clicking the [X] in the window
4. On exit the rednotebook process SEGFAULTS in (output from dmesg)

[ 219.442756] rednotebook[1634]: segfault at 0 ip 00007f2857306f74 sp 00007fff2f25eee0 error 4 in[7f28571e2000+2d5000]

Apologies if this is not the right place to report this. I tried downgrading the qt4 package and unfortunately that didn't fixing anything but the segfault is happening in libQtCore according to the output of dmesg. Based on looking at the output of strace the last thing that happens before segfaulting is

stat("/usr/lib/kde4/plugins", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0

I've attached the whole output of running

$ rednotebook 2>&1 | tee rednotebook-segfault.txt

Any guidance on how to debug this would be helpful? Should I rebuild with debug symbols and then attach to the python process and hope that that will catch the segfault?
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Tuesday, 18 March 2014, 11:14 GMT
Reason for closing:  Upstream
Additional comments about closing:  rednotebook is not supported
Comment by Dan Liew (delcypher) - Monday, 10 March 2014, 11:41 GMT
Sorry, mistake in my last sentence.

s/attach to the python process/attach gdb to the python process/
Comment by Andrea Scarpino (BaSh) - Monday, 17 March 2014, 18:31 GMT
This cannot be a bug in qt4...try removing qt4 (use pacman -Rdd qt4), run the application and then install qt4 again...
Comment by Dan Liew (delcypher) - Tuesday, 18 March 2014, 10:34 GMT
Well that's weird.

I removed qt4 and ran rednotebook and no segfault. I then reinstalled qt4 and tried rednotebook and as before it is segfaulting in rednotebook when I exit.

I've just noticed however that if I strip out a particular environment variable then the segfault does not happen, i.e.

$ env --unset=KDE_FULL_SESSION rednotebook

When I use my normal environment (contains KDE_FULL_SESSION=true) then when I run rednotebook from the command line it segfaults in libQtCore on exit.
Comment by Andrea Scarpino (BaSh) - Tuesday, 18 March 2014, 11:14 GMT
Thank you for your investigation. You should report this upstream since it doesn't seems to be a packaging bug or a qt one.