Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39239 - [awesome][mesa] Couldn't start awesome with mesa 10.1.0-2

Attached to Project: Arch Linux
Opened by Dmitry Chusovitin (dchusovitin) - Saturday, 08 March 2014, 20:10 GMT
Last edited by Laurent Carlier (lordheavy) - Saturday, 08 March 2014, 21:49 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Awesome WM crashes with new mesa package

awesome: error while loading shared libraries: libEGL.so.1: cannot open shared object file: No such file or directory

Additional info:
* package version(s)
mesa = 10.1.0-2
awesome = 3.5.2-1

* config and/or log files etc.
Xorg.log - http://pastebin.com/8v0tYwj5

Steps to reproduce:
Install awesome, mesa and run 'xinit /usr/bin/awesome'
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Saturday, 08 March 2014, 21:49 GMT
Reason for closing:  None
Additional comments about closing:  catalyst isn't in our repo
Comment by Dmitry Chusovitin (dchusovitin) - Saturday, 08 March 2014, 20:27 GMT
This error occurs because the package 'mesa-libgl' is not installed on my mashine. But I can't install package because catalyst drivers conflicts with 'mesa-libgl'
libEGL.so.1 moved from 'mesa' to 'mesa-libgl' package - https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/mesa&id=aa6bfe92f4cd15ae418f511c671f87fcc1599fc9
Comment by Laurent Carlier (lordheavy) - Saturday, 08 March 2014, 21:49 GMT
* best solution: catalyst should provide libEGL, libGLESv1_CM, .....
* only solution available: catalyst should provide symlinks to libEGL, libGLESv1_CM ,... provided by mesa

Loading...