Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39209 - [phpmyadmin] phpmyadmin doesn't work with apache 2.4 and php-fpm

Attached to Project: Community Packages
Opened by patrick (potomac) - Friday, 07 March 2014, 02:15 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Tuesday, 25 March 2014, 08:49 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

since apache2.4 package it's impossible to use phpmyadmin package, apache fails to start, with these error messages :

AH00526: Syntax error on line 7 of /etc/httpd/conf/extra/httpd-phpmyadmin.conf:
apachectl[4743]: Invalid command 'php_admin_value', perhaps misspelled or defined by a module not included in the server configuration

I don't find the solution in archlinux wiki page

Additional info:
* package version(s) phpmyadmin 4.1.8-1, apache 2.4.7-1, php 5.5.10-1, php-apache 5.5.10-1, php-fpm 5.5.10-1


* config and/or log files etc.


Steps to reproduce:
- install apache 2.4
- install php and php-fpm
- install phpmyadmin

if you follow the archlinux wikipage ( phpmyadmin ) apache 2.4 won't start
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Tuesday, 25 March 2014, 08:49 GMT
Reason for closing:  Not a bug
Comment by Bartłomiej Piotrowski (Barthalion) - Friday, 07 March 2014, 12:18 GMT
It's not a problem with the package, but with your configuration. Look at our forums for assistance. Closing.
Comment by Joyce Markoll (Melodie) - Tuesday, 25 March 2014, 00:25 GMT
  • Field changed: Percent Complete (100% → 0%)
I meet with the exact same annoyance that presented in this bug report and there is no obvious solution. I think the bug should really be reported against phpmyadmin as it probably needs an update of the configuration file.

Please take note that my configuration is the one provided by the apache packages where I just added my server name and the request to include the httpd-phpmyadmin.conf
Comment by patrick (potomac) - Tuesday, 25 March 2014, 02:30 GMT
the workaround: set the httpd-phpmyadmin.conf file like this :

Alias /phpmyadmin "/usr/share/webapps/phpMyAdmin"
<Directory "/usr/share/webapps/phpMyAdmin">
AllowOverride All
Options FollowSymlinks
Require all granted
</Directory>

and check if in /etc/php/php.ini the open_basedir option contains these paths : /usr/share/pear/ and /usr/share/webapps/

Loading...