Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39193 - libpng error with GIMP

Attached to Project: Arch Linux
Opened by GI Jack (GI_Jack) - Wednesday, 05 March 2014, 21:31 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 05 March 2014, 21:59 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
GIMP fails to save PNGs, when exported type is PNG.

Additional info:
* package version(s)
gimp 2.8.10-1
libpng 1.6.9-1

* config and/or log files etc.
, error message in the GUI:
Saving '/path/to/somefile.png' failed:

Error while saving '/path/to/somefile.png'. Could not save image.

And this comes from stderr:
Metadata parasite seems to be corrupt
lcms: skipping conversion because profiles seem to be equal:
sRGB IEC61966-2.1
sRGB built-in
libpng error: Read Error
...
libpng error: known incorrect sRGB profile

(file-png:8720): GLib-WARNING **: (gerror.c:390):g_error_new_valist: runtime check failed: (domain != 0)

Steps to reproduce:
install GIMP, open up an image file in GIMP, menu:

File -> Export As

select PNG from type menu.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 05 March 2014, 21:59 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#35363 

Loading...