Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39184 - [eclipse] crash at launch

Attached to Project: Arch Linux
Opened by Laël Guillemenot (zeppelinlg) - Wednesday, 05 March 2014, 16:11 GMT
Last edited by Jan de Groot (JGC) - Monday, 21 April 2014, 16:44 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Jan Steffens (heftig)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 14
Private No

Details

Description:
Eclipse crash just after launching. The downgrade of webkitgtk2 from 2.2.5-2 to 1.10.2-8 resolve this issue

Additional info:
* eclipse package 4.3.2-2
* output from commandline :
$ eclipse
No bp log location saved, using default.
[000:000] Cpu: 6.58.9, x4, 3600Mhz, 5845MB
[000:000] Computer model: Not available
No bp log location saved, using default.
[000:000] Cpu: 6.58.9, x4, 3600Mhz, 5845MB
[000:000] Computer model: Not available
[000:000] Browser XEmbed support present: 1
[000:000] Browser toolkit is Gtk2.
[000:000] Using Gtk2 toolkit
[000:006] Warning(optionsfile.cc:47): Load: Could not open file, err=2
[000:006] No bp log location saved, using default.
[000:006] Cpu: 6.58.9, x4, 3600Mhz, 5845MB
[000:006] Computer model: Not available
[000:006] Browser XEmbed support present: 1
[000:006] Browser toolkit is Gtk2.
[000:006] Using Gtk2 toolkit
[000:011] Warning(optionsfile.cc:47): Load: Could not open file, err=2
[000:012] No bp log location saved, using default.
[000:012] Cpu: 6.58.9, x4, 3600Mhz, 5845MB
[000:012] Computer model: Not available
[000:008] Warning(optionsfile.cc:47): Load: Could not open file, err=2
[000:008] No bp log location saved, using default.
[000:008] Cpu: 6.58.9, x4, 3600Mhz, 5845MB
[000:008] Computer model: Not available
[000:008] Browser XEmbed support present: 1
[000:008] Browser toolkit is Gtk2.
[000:008] Using Gtk2 toolkit
[000:013] Warning(optionsfile.cc:47): Load: Could not open file, err=2
[000:013] No bp log location saved, using default.
[000:014] Cpu: 6.58.9, x4, 3600Mhz, 5845MB
[000:014] Computer model: Not available
java version "1.7.0_51"
OpenJDK Runtime Environment (IcedTea 2.4.5) (ArchLinux build 7.u51_2.4.5-1-x86_64)
OpenJDK 64-Bit Server VM (build 24.51-b03, mixed mode)
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 21 April 2014, 16:44 GMT
Reason for closing:  Fixed
Comment by Jan Steffens (heftig) - Wednesday, 05 March 2014, 17:26 GMT
Works for me.
Comment by Doug Newgard (Scimmia) - Wednesday, 05 March 2014, 17:44 GMT
I haven't been able to reproduce it, either, but others on the forum have: https://bbs.archlinux.org/viewtopic.php?id=177983
Comment by David Rosenstrauch (darose) - Wednesday, 05 March 2014, 18:00 GMT
I'm experiencing this issue as well - even after upgrading to eclipse 4.3.2-2.
Comment by Linus Probert (LiquidityC) - Wednesday, 05 March 2014, 20:48 GMT
Clarification. Crash is caused when javadoc is displayed. For example hovering a java class with mouse or using autocompletion (ctrl + space).
Comment by Jan Steffens (heftig) - Wednesday, 05 March 2014, 22:56 GMT
Still works for me - javadoc popups and the help browser both work.
Comment by Saad Malik (SimFox3) - Thursday, 06 March 2014, 01:33 GMT
With the webkitgtk2-2.2.5 update, Eclipse intermittently started crashing every 4-5 minutes, especially when performing remote debugging. As soon as I downgraded to previous webkitgtk2-1.10.2-8, issues disappeared. Related post: https://bbs.archlinux.org/viewtopic.php?pid=1388898
Comment by Andrew Gaydenko (student975) - Thursday, 06 March 2014, 06:59 GMT
I have the issue also with Eclipse downloaded from upstream. Downgrading webkitgtk2 permits at least to set using of external browser (with last webkitgtk2 crash takes place - 100% reproducible at my case - in browser settings dialog from Eclipse preferences also, not only in editor). With webkitgtk2 1.10.2-8 I also have got a crash with internal browser selected. Will further test with external one.
Comment by Linus Probert (LiquidityC) - Thursday, 06 March 2014, 07:54 GMT
Adding

-Dorg.eclipse.swt.browser.DefaultType=mozilla

to eclipse.ini has been a workaround. Those of you who aren't having this problem might have something similar already configured in your eclipse.ini or eclipse on your setups is automatically choosing some other lib to render html.
Comment by Jan Steffens (heftig) - Thursday, 06 March 2014, 15:23 GMT
Here, it's definitely using the WebKit renderer. Setting the above option breaks the internal browser and forces all pages to be opened in Firefox, which I guess is because the Mozilla Binding plugin which provides the Xulrunner bridge is not installed. The default installation only ships the WebKit plugin.

Is your Eclipse loading both the Xulrunner and the WebKit libraries, even if only the latter are used? Libxul is linked against GStreamer 0.10 and webkitgtk is linked against GStreamer 1.0, which will cause crashes if both are loaded.
Comment by Andrew Gaydenko (student975) - Thursday, 06 March 2014, 15:40 GMT
I haven't xulrunner package installed, but google-talkplugin creates links to own libs:

~ $ sudo pacman -Qo /usr/lib/xulrunner
/usr/lib/xulrunner is owned by google-talkplugin 5.1.5.0-1
~ $ ls -als /usr/lib/xulrunner
total 248
4 drwxr-xr-x 3 root root 4096 окт 7 20:24 .
240 drwxr-xr-x 258 root root 241664 мар 6 17:53 ..
4 drwxr-xr-x 2 root root 4096 мар 1 08:04 plugins
~ $ ls -als /usr/lib/xulrunner/plugins/
total 8
4 drwxr-xr-x 2 root root 4096 мар 1 08:04 .
4 drwxr-xr-x 3 root root 4096 окт 7 20:24 ..
0 lrwxrwxrwx 1 root root 52 мар 1 07:47 libnpgoogletalk.so -> ../../../../opt/google/talkplugin/libnpgoogletalk.so
0 lrwxrwxrwx 1 root root 58 мар 1 07:47 libnpgtpo3dautoplugin.so -> ../../../../opt/google/talkplugin/libnpgtpo3dautoplugin.so
0 lrwxrwxrwx 1 root root 45 мар 1 07:47 libnpo1d.so -> ../../../../opt/google/talkplugin/libnpo1d.so
~ $
Comment by Arjen Schol (arjen) - Tuesday, 11 March 2014, 12:39 GMT
Could this be GPU related? webkitgtk2-2.2.5 crashes workstation at home (ATI GPU), but works fine at office (Nvidia GPU) using the same eclipse, plugins and source code versions.
Comment by Linus Probert (LiquidityC) - Tuesday, 11 March 2014, 12:41 GMT
Come to think of it I have a similar scenario. Works at home (nvidia), gives trouble at work (intel).
Comment by Andrew Gaydenko (student975) - Tuesday, 11 March 2014, 12:57 GMT
I have a crash using proprietary nvidia driver.
Comment by Saad Malik (SimFox3) - Tuesday, 11 March 2014, 16:32 GMT
Sony Vaio laptop with integrated Intel chip set, but it still crashes.
Comment by Laël Guillemenot (zeppelinlg) - Thursday, 13 March 2014, 09:09 GMT
I have a crash using proprietary nvidia driver.
Comment by Michael Berg (jk799) - Thursday, 13 March 2014, 12:44 GMT
I can reproduce this too. Downgrading from 2.2.5-2 to 1.10.2-8 makes eclipse stable again. Using intel graphics.
Comment by Karol Babioch (johnpatcher) - Thursday, 13 March 2014, 13:10 GMT
Just another confirmation that downgrading 1.10.2-8 does solve this issue for me. I'm using nouveau. The crash didn't occur at the start iself, but mostly when some sort of auto completion was suggested, i.e. whenever the popup with suggestions appeared.
Comment by Karol Babioch (johnpatcher) - Friday, 14 March 2014, 17:25 GMT
There seems to be a patch, though I haven't tested it yet: https://bugs.webkit.org/show_bug.cgi?id=129784
Comment by Michael Berg (jk799) - Monday, 17 March 2014, 12:11 GMT
Applying the patch and trying to provoke the error within eclipse again. BRB.
Comment by Michael Berg (jk799) - Monday, 17 March 2014, 18:15 GMT
OK I got exited a litte too early. Eclipse crashes anyway. :(
Comment by Saad Malik (SimFox3) - Monday, 17 March 2014, 18:31 GMT
Darn--I was hoping the patch would've fixed the issue.
Comment by Karol Babioch (johnpatcher) - Tuesday, 15 April 2014, 00:26 GMT
Eclipse appears to be stable for me again after having upgraded to GNOME 3.12 (which also included an upgrade of webkitgtk2 from 1.10.2-8 to 2.4.0-1). Maybe others can confirm this, so that the bug can be closed?
Comment by Jorge Merlino (Drencrom) - Tuesday, 15 April 2014, 03:49 GMT
In my case I solved it following the suggestions here: https://bugs.eclipse.org/bugs/show_bug.cgi?id=334466#c37
I updated both googletalk plugin (from aur) and webkit and all works fine now.
I think the bug should be closed
Comment by Laël Guillemenot (zeppelinlg) - Thursday, 17 April 2014, 17:14 GMT
Looks good to me with :
webkitgtk-2.4.0-1-x86_64
webkitgtk2-2.4.0-1-x86_64

Loading...