Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39147 - [cups] package contains directories in /run

Attached to Project: Arch Linux
Opened by Uli (Army) - Tuesday, 04 March 2014, 13:44 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 04 March 2014, 18:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

In my update script I have among others this command, which produces this output

# pacman -Qkq
cups /run/cups/
cups /run/cups/certs/

Since /run is mounted as tmpfs

# mount | grep /run
run on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)

this doesn't make a lot of sense.

Additional info:
* package version(s)
cups 1.7.1-3

Steps to reproduce:

Install cups and run

pacman -Qkq | grep cups
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 04 March 2014, 18:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.7.1-4
Comment by Uli (Army) - Tuesday, 04 March 2014, 13:45 GMT
Ok, a better command would be

pacman -Qkq cups

:D But the result is the same, that's what matters here ;)
Comment by Andreas Radke (AndyRTR) - Tuesday, 04 March 2014, 16:15 GMT
check https://www.cups.org/documentation.php/doc-1.7/security.html

"Local certificate authentication passes 128-bit "certificates" that identify an authenticated user. Certificates are created on-the-fly from random data and stored in files under /var/run/cups/certs."

So the certs belong to /run in Arch. Not a bug.
Comment by Doug Newgard (Scimmia) - Tuesday, 04 March 2014, 16:55 GMT
  • Field changed: Percent Complete (100% → 0%)
He's right, it doesn't make any sense for the package to contain dirs on tmpfs. falconindy recently opened  FS#39148  for the same reason on another package.
Comment by Dave Reisner (falconindy) - Tuesday, 04 March 2014, 16:56 GMT
> So the certs belong to /run in Arch. Not a bug.
They absolutely do, but after a reboot, /run/cups/certs will not exist. A tmpfiles.d fragment needs to be added to the cups package to ensure that this is created on startup.

It should be sufficient to create /usr/lib/tmpfiles.d/cups.conf with contents:

d /run/cups/certs 0755 0 0

Please make sure to call this from post_install and post_upgrade as:

systemd-tmpfiles --create cups.conf
Comment by Andreas Radke (AndyRTR) - Tuesday, 04 March 2014, 18:22 GMT
The /run/cups directory get recreated after each server restart. So it should be safe to remove it from the package.

Loading...