Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#39143 - [wireshark-cli] Segfault running "tshark -G values"

Attached to Project: Community Packages
Opened by Moritz Bunkus (mbunkus) - Tuesday, 04 March 2014, 11:12 GMT
Last edited by Timothy Redaelli (tredaelli) - Wednesday, 23 April 2014, 15:25 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Timothy Redaelli (tredaelli)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

tshark can dump several of its internal databases with "tshark -G type". With "type" = "values" this works more or less, but segfaults after a long list of known values has been output. It is unclear whether or not more known values would have to be output or if that segfault occurs after all of them have been output.

Looks like this:

[139 mbunkus@chai-latte ~] tshark -G values
[1 mbunkus@chai-latte ~] tshark -G values|head
V ieee17221.message_type 0 ENTITY_AVAILABLE
V ieee17221.message_type 1 ENTITY_DEPARTING

V btsdp.service_uuid 0x1801 Generic Attribute Profile
zsh: segmentation fault (core dumped) tshark -G values
[139 mbunkus@chai-latte ~]

All other supported arguments to "-G" work fine without segfaulting.

Additional info:
* wireshark-cli 1.10.5-3 on a system "pacman -Syu"'ed yesterday


Steps to reproduce:

Install wireshark-cli. Run "tshark -G values". Observe segfault.
This task depends upon

Closed by  Timothy Redaelli (tredaelli)
Wednesday, 23 April 2014, 15:25 GMT
Reason for closing:  Fixed
Additional comments about closing:  Seems fixed with wireshark 1.10.6-1
Comment by Moritz Bunkus (mbunkus) - Tuesday, 04 March 2014, 13:08 GMT
I've decided to check further: it's fixed in their development version (git »master« branch). I've filed a bug report upstream at https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=9834 though because the issue is present in the current release branch.

Loading...